sdl link connection refused on Call Manager

Answered Question
Jul 3rd, 2007
User Badges:

I upgraded publisher to 4-2-3-sr2b. All OK. When I attempt to upgrade subscriber, it fails, and now these errors are all over the application logs of both servers...


Event Type: Error

Event Source: Cisco CallManager

Event Category: None

Event ID: 3

Date: 7/3/2007

Time: 8:07:25 AM

User: N/A

Computer: CM_SUB_DC

Description:

Error: SDLLinkAppProtocol - SDL Link Connection Refused.

Remote Application Link Protocol Version: D

Local Application Link Protocol Version: C

Remote Node ID: 1

Remote Application ID: 200

Remote Application Version: 4.2(3.13216)

App ID: Cisco CallManager

Cluster ID: CM_Cluster

Node ID: xx.xx.xx.xx

Explanation: This alarm indicates that the local Cisco CallManager is unable to establish communication with the remote Cisco CallManager due to a protocol version mismatch.

Recommended Action: Determine the release numbers of the local and remote Cisco CallManager servers. If the releases do not match, it's possible that the local and remote Cisco CallManager servers cannot communicate due to protocol changes. To correct the problem, upgrade the appropriate Cisco CallManager so that the versons of the local and remote Cisco CallManager servers match..


I understand what it means, and by comparing the application version tags of each corresponding error, I can see the versions are different, but the solution offered is upgrade the server, which I can't do.


I've got CSA and anti-virus disabled, I tried rebooting everything.


Any suggestions? I can't find anything on this error.


Edit: I should mention, calling functions from each office are working, but neither site can call the other directly. Fast busy when dialing the extension of sub from pub or vice versa.

Correct Answer by jbarcena about 9 years 9 months ago

I recommend you to uninstall the SR on both servers, leave them as plain 4.2(3), then run the DBLHelper to check the replication, if necessary try a Republish. Once you have green faces and SDL link is back up then upgrade to the same SR on both servers.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
jbarcena Tue, 07/03/2007 - 04:45
User Badges:
  • Red, 2250 points or more

Well it is expected that you are not able to call between servers (ext. from pub to ext. from sub or viceversa) because the SDL link between the servers is down. If you do not have the same CCM version (including SR or ES) on both servers nor the exact OS version including SR on both servers there is not much that you can do here. Once you have the same versions you just need to reboot the servers or restart the CCM service to bring the SDL link back up.

kdotten36 Tue, 07/03/2007 - 04:49
User Badges:

well yea, the problem and the solution is upgrading the server.


it won't let me.


I have the same OS on both machines, and am using the same install file for the CM Software upgrade. The subscriber just sits between 30-45 minutes, flipping between "Initializing Subscriber Database" and "Waiting for Subscriber Database to complete Initialization (maybe not exact wording)" and finally bombs out with a Replication Failure error.



jbarcena Tue, 07/03/2007 - 04:51
User Badges:
  • Red, 2250 points or more

From which version to which version are you trying to upgrade?


Do you have the installation log? Please upload it.

Correct Answer
jbarcena Tue, 07/03/2007 - 05:05
User Badges:
  • Red, 2250 points or more

I recommend you to uninstall the SR on both servers, leave them as plain 4.2(3), then run the DBLHelper to check the replication, if necessary try a Republish. Once you have green faces and SDL link is back up then upgrade to the same SR on both servers.

kdotten36 Tue, 07/03/2007 - 05:15
User Badges:

Right, that's probably what will end up being done if TAC can't help. I'm trying to avoid the business impact on the publisher. The subscriber I can afford to drop for a bit, but a rollback of the pub would have to be done tonight which means faulty phone system for a day.

eug-c Tue, 07/03/2007 - 05:38
User Badges:

Hi,


I have encountered this before and there is only one thing to do, that is to open a TAC case and to let TAC remote access your CCM setup.


The reason that TAC gave me the previous time was that somehow during the upgrade, the CCM ID in the SQL database was changed and secondly, when an upgrade was done, there was some differences in the database and therefore some columns were missing. After changing these, I did not see this SDL error anymore.


I tried searching for the changes that TAC did and it was not documented anywhere in CCO.


Don't worry, it is a solvable problem.

HTH,

:)

eug-c Tue, 07/03/2007 - 05:41
User Badges:

Oh yes, one more thing is when i had the problem, I tried to run the DBLhelper and it showed a green face. All Sql replication seems to be ok, but I still had the SDL error.


I also did a reupgrading of the server and it still had the same problem.


:)

Amith Kumar Mon, 07/30/2007 - 11:35
User Badges:

I had this problem when I was upgrading SR for 4.1(3). I had to start all the services in the subscriber and then start the installation. That resolved the situation.


Anywayz, do you still have the problem or is it resolved?

kdotten36 Tue, 07/31/2007 - 04:45
User Badges:

no, uninstalling the SRs cleared that error, but the real problem i found later was that the replication database had gone suspect. I had to rebuild the publisher.

Actions

This Discussion