Redistributing OSPF and eigrp

Answered Question
Jul 3rd, 2007

We have a medium size network consisting of 14 locations connected to one location via a mixture of T-1?s , fiber, wide area wireless and metro e. We us a mixture of Cisco and Dell switches.

We have run in to a problem combining the Cisco and the Dell and need some guidance.

The locations that come to us via the P2P T-1?s start at the branch locations on 2620 Cisco routers and run back to 3600 Cisco router ? we are currently using router eigrp to define our networks.

The problem that we are having at one location is that we have a layer 3 Dell switch behind the 2620 - the Dell switches will run OSPF and not Eigrp ? this there a way to have Eigrp advertise the the OSPF information it receives?

OR may be to sum it up better can you run Eigrp on the outside interface that passes OSPF from the internal interface?

Or is there a better way to do what I?m trying to do?

Any help is greatly welcome

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 9 years 5 months ago

Hi

On the 2620 under

router ospf 1

redistribute eigrp 100 subnets

HTH

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Jon Marshall Tue, 07/03/2007 - 08:48

Hi

yes there is no reason why you cannot run OSPF and EIGRP on the same router and redistribute between the 2 protocols.

Alternatively could you not just put a static route on the Dell switch pointing to the 2620 and a static route(s) on the 2620 pointing to the subnets on teh Dell switch. The static route on the 2620 could be redistributed into EIGRP.

It all depends on how many networks there are on and behind the Dell switch.

HTH

Jon

j4boat2232 Tue, 07/03/2007 - 08:57

Thank you Jon,

To make it work that is what we did - but tring to clean thinks up a little and remove as many static routes as possible we where toying with the OSPF on the inside and EIGRP on the out side - the 2620 can see the ospf routes from the DEll but be can't get those to play nicely with the out going EIGRP - packets get to the 3600 that should be bound for the 2620 and keep getting lost. can you lead me to a white paper that my clear up my problems?

Thank you again for your input

j4boat2232 Tue, 07/03/2007 - 09:08

Please see below config on the 2620:

ip subnet-zero

!

lane client flush

cns event-service server

!

!

!

!

!

interface FastEthernet0/0

ip address 10.100.187.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

description *** NEW T-1 to admin ***

ip address 10.100.181.10 255.255.255.252

no ip mroute-cache

no fair-queue

!

router eigrp 100

redistribute connected

redistribute ospf 1

network 10.0.0.0

no auto-summary

!

router ospf 1

network 10.100.0.0 0.0.255.255 area 0.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.100.181.9

no ip http server

!

And on the 3600

interface Serial2/0

description *West Circuit ID 60.DHZ T-1

ip address 10.100.181.9 255.255.255.252

no cdp enable

!

router eigrp 100

network 10.100.178.0 0.0.0.255

network 10.100.181.0 0.0.0.3

network 10.100.181.4 0.0.0.3

network 10.100.181.8 0.0.0.3

network 10.100.181.12 0.0.0.3

network 10.100.181.16 0.0.0.3

network 10.100.181.20 0.0.0.3

network 10.100.181.24 0.0.0.3

network 10.100.181.28 0.0.0.3

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.100.177.2

ip route 10.100.150.0 255.255.254.0 10.100.181.10

ip route 10.100.152.0 255.255.254.0 10.100.181.10

ip route 10.100.154.0 255.255.254.0 10.100.181.10

ip route 10.100.154.0 255.255.255.0 10.100.181.10

ip route 10.100.155.0 255.255.255.0 10.100.181.10

ip route 10.100.158.0 255.255.255.0 10.100.181.10

ip route 10.100.187.0 255.255.255.0 10.100.181.10

ip route 10.100.188.0 255.255.255.0 10.100.181.10

ip route 10.100.190.0 255.255.255.0 10.100.181.10

ip route 10.100.192.0 255.255.255.0 10.100.181.10

ip route 10.100.199.0 255.255.255.0 10.100.181.6

ip http server

Thank you I will also review the link you sent.

Amit Singh Tue, 07/03/2007 - 09:49

I see that you are doing only one way redistribution i.e redistrbuting OSPF into EIGRP, this way the OSPF routes from dell switch will be advertised in the EIGRP domains but the EIGRP routes will not be advertised in the OPSF domain.

If you are connected to Dell switch you will not be able to reach any EIGRP subnet untill you redistribute the EIGRP into OSPF which is called as mutual redistribution. Another way is to redistribute the default route into OSPF which is configured to 2620 routers.

My suggestion is to configure the mutual redistribution on the 2620 router and you should be fine with it.

HTH,Please rate if it does.

-amit singh

j4boat2232 Tue, 07/03/2007 - 10:01

That make it a little clear - we are currently only talking one why. Where would I find the commands to do mutual redistribution?

Thank you - you all have been a great help in clearing this up

Correct Answer
Jon Marshall Tue, 07/03/2007 - 10:22

Hi

On the 2620 under

router ospf 1

redistribute eigrp 100 subnets

HTH

Jon

Actions

This Discussion