connecting a pc on the ethernet port of the 2600 router

Answered Question
Jul 4th, 2007

I am trying to connect a pc on the ethernet port of the router (2600). I have assigned eth 0/0 10.1.3.1 255.255.255.0. (show ip interface command shows the status UP & UP). I have used a crossover cable to connect to the pc. I have assigned static 10.1.3.2 255.255.255.0 for the NIC. But now i can only ping 10.1.3.1 nothing else and also i cant ping 10.1.3.2 from the router. What am I doing wrong here? I want to use the pc as the tftp server.

thanks for your help

I have this problem too.
0 votes
Correct Answer by mohammedmahmoud about 6 years 9 months ago

Hi Rajib,

Lets build-up a baseline:

PC(10.1.3.2/24)<-->(10.1.3.1/24)Router(5.0.2.2/24)

To ping from the PC to 10.1.3.1, its directly connected and needs no routing and should work, to ping from the PC to 5.0.2.2 needs the PC to have the router IP (10.1.3.1) as its default gateway.

NOTE that the IP addressing must be consistent (any 2 interfaces sharing the same media must have IPs in the same subnet).

Please comment on my input, and please share us your topology.

I hope that i've been informative.

HTH,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
mohammedmahmoud Wed, 07/04/2007 - 23:07

Hi,

You should use cross-over cable as you are doing, please make sure that the firewall on the PC is disabled.

HTH,

Mohammed Mahmoud.

rajibchicago Thu, 07/05/2007 - 01:32

I dont think it is a firewall issue but still i disable the firewall on the windows pc. But same thing, I can only from the pc ping the IP address on the router ethernet interface nothing else, cant even ping the serial interface ip address on the same router (reply i am receiving is destination host unreachable.) and from the router cant ping the nic. thanks

rajibchicago Thu, 07/05/2007 - 01:55

I believe it is a routing issue, That router serial interface has an ip address 5.0.2.2 255.255.255.0, I changed the ethernet 0/0 ip address to 5.0.3.1 /24 now i can ping from the router to the pc, but then i am stuck again, i cant ping from the pc to the router's serial interface (ip 5.0.2.2) or any other router nor can i ping from the other router to the nic. seems like the router is not routing for the ethernet 0 interface. any help will be really appreciated. thanks

Correct Answer
mohammedmahmoud Thu, 07/05/2007 - 02:29

Hi Rajib,

Lets build-up a baseline:

PC(10.1.3.2/24)<-->(10.1.3.1/24)Router(5.0.2.2/24)

To ping from the PC to 10.1.3.1, its directly connected and needs no routing and should work, to ping from the PC to 5.0.2.2 needs the PC to have the router IP (10.1.3.1) as its default gateway.

NOTE that the IP addressing must be consistent (any 2 interfaces sharing the same media must have IPs in the same subnet).

Please comment on my input, and please share us your topology.

I hope that i've been informative.

HTH,

Mohammed Mahmoud.

rajibchicago Thu, 07/05/2007 - 03:37

I DID not set up the default gateway - that was the problem. After setting up the default gateway, the problem had been resolved. thanks againg mohammed mahmoud. I really appreciate that.

I changed the setup (connect the ethernet cable to a different router to test if there were any problem in the interface). now the way it is now:

pc (5.0.3.2/24)----ethernet ---> router (5.0.3.1/24) serial interface (5.0.2.2/24). thanks again for solving this puzzle for me.

mohammedmahmoud Thu, 07/05/2007 - 03:50

Hi Rajib,

You are very welcomed again :)

Keep up the nice work, and as a best practice use /30 IPs on serial interfaces as in this scenario you only need 2 host IPs on the serial link, and if you are using RIP make sure to use RIPv.2 in order not to go into any classful/discontigous problems.

HTH,

Mohammed Mahmoud.

Actions

Login or Register to take actions

This Discussion

Posted July 4, 2007 at 10:34 PM
Stats:
Replies:9 Avg. Rating:5
Views:420 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard