GRE-tunnel

Unanswered Question
Jul 5th, 2007
User Badges:

Hi,


Is this normal behaviour when I have a GRE tunnel between PE and CPE? When I tried to icmp from PE to CPE tunnel address I got the following output in CPE and the ping fails.


Jul 4 16:52:57: Tunnel1: adjacency fixup, 10.36.73.1->10.36.85.156, tos=0x0


The tunnel is up but ping fails and I have configured ip mtu 1476 and ip tcp adjust-mss 1436 in CPE.


The same configuration works in other CPE and configuration is same.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Thu, 07/05/2007 - 04:40
User Badges:
  • Green, 3000 points or more

Can you post the configurations..


komuja1 Thu, 07/05/2007 - 05:30
User Badges:

Here are the configurations:

---------------------------------

CPE

interface Tunnel1

ip address 10.10.10.1 255.255.255.252

ip mtu 1476

ip tcp adjust-mss 1436

tunnel source FastEthernet0.1567

tunnel destination 10.10.10.5

!

interface FastEthernet0.1567

encapsulation dot1Q 1567

ip address 10.10.11.1 255.255.255.252

ip accounting output-packets

!

ip route 0.0.0.0 0.0.0.0 10.10.10.2

ip route 10.10.10.5 255.255.255.255 10.10.11.2


PE


interface Tunnel10013

ip vrf forwarding customer_a

ip address 10.10.10.2 255.255.255.252

tunnel source Loopback1003

tunnel destination 10.10.11.1

end


interface GigabitEthernet0/3.111

encapsulation dot1Q 111

ip address 10.10.11.2 255.255.255.252


interface Loopback1003

ip address 10.10.10.5 255.255.255.255

!

ip route vrf customer_a 10.10.11.0 255.255.255.252 GigabitEthernet0/3.111 10.10.11.1

----------------------------------


I can ping between link address (also MTU 2000)but norman ping won't work over the tunnel. The link from CPE to PE goes via ME-switch.


I also have same configuration where CPE and PE are connected via ATM network and it works fine.

Richard Burts Thu, 07/05/2007 - 12:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jarmo


I have been trying to understand the relationship of the addresses given in the error message in your original post:

Jul 4 16:52:57: Tunnel1: adjacency fixup, 10.36.73.1->10.36.85.156, tos=0x0

and the addresses shown in the partial config that you posted. I am confused. Can you clarify what the addresses are in the error message and how they relate to the routers running the tunnel?


HTH


Rick

sundar.palaniappan Thu, 07/05/2007 - 13:45
User Badges:
  • Green, 3000 points or more

Jarmo,


I agree with Rick that it's unclear how the error message relates to the problem you described. It sounds like you are able to ping across the lan link fine but it only fails when you ping across the GRE tunnel. You have the MTU set to 1476 on the CE tunnel int but not on the PE. Can you set the MTU to 1476 on the PE tunnel int 10013 as well and test?


HTH


Sundar

komuja1 Thu, 07/05/2007 - 21:25
User Badges:

Hi,


I made a change the configrations in yesterday and I posted a different config's..sorry about that.


this is the original config and I also sent a debug messages when this configration is valid and when I tried to icmp PE to CPE. I will try to set PE tunnel 10013 MTU 1476 and inform you.


CPE

---------------------------------------

!

interface Tunnel1

ip address 10.36.85.145 255.255.255.252

ip mtu 1476

ip tcp adjust-mss 1436

tunnel source FastEthernet0.1567

tunnel destination 10.36.85.156

!

interface FastEthernet0.1567

encapsulation dot1Q 1567

ip address 10.36.73.1 255.255.255.252

ip accounting output-packets

!

ip route 0.0.0.0 0.0.0.0 10.36.85.146

ip route 10.36.85.156 255.255.255.255 10.36.73.2

!


debug messages in CPE

Tunnel1: GRE/IP encapsulated 10.36.73.1->10.36.85.156 (linktype=7, len=80)

Tunnel1: adjacency fixup, 10.36.73.1->10.36.85.156, tos=0x0

Tunnel1: adjacency fixup, 10.36.73.1->10.36.85.156, tos=0x0

Tunnel1: adjacency fixup, 10.36.73.1->10.36.85.156, tos=0x0

Tunnel1: adjacency fixup, 10.36.73.1->10.36.85.156, tos=0x0

!

IP: tableid=0, s=10.36.85.146 (Tunnel1), d=10.36.85.145 (Tunnel1), routed via RIB

IP: s=10.36.85.146 (Tunnel1), d=10.36.85.145 (Tunnel1), len 100, rcvd 3

!

-----------------------------------------

PE


interface Tunnel10013

ip vrf forwarding customer_a

ip address 10.36.85.146 255.255.255.252

tunnel source Loopback1003

tunnel destination 10.36.73.1

!

interface Loopback1003

ip address 10.36.85.156 255.255.255.255

!

interface GigabitEthernet0/3.111

encapsulation dot1Q 111

ip address 10.36.73.2 255.255.255.252

!

ip route vrf customer_a 10.36.73.0 255.255.255.252 GigabitEthernet0/3.111 10.36.73


The debug in PE


Tunnel10013: GRE/IP to classify 10.36.73.1->10.36.85.156 (len=130 ttl=254 tos=0x0)

Tunnel10013: GRE/IP to classify 10.36.73.1->10.36.85.156 (len=130 ttl=254 tos=0x0)

Tunnel10013: GRE/IP to classify 10.36.73.1->10.36.85.156 (len=130 ttl=254 tos=0x0)


br

Jarmo


Richard Burts Fri, 07/06/2007 - 07:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jarmo


It would be easier to know if it were normal if we knew exactly what debugs you had running and what version of IOS you were running.


This message on the CPE indicates that you did receive 3 packets over the tunnel, which would seem to be the icmp that you sent:

IP: s=10.36.85.146 (Tunnel1), d=10.36.85.145 (Tunnel1), len 100, rcvd 3

It is not clear whether you sent responses and if not why not. I assume that this debug was from debug ip packet on CPE. Are you running this debug also on PE? If not it would help to see that debug on both routers.


HTH


Rick

Actions

This Discussion