VLAN Access Maps and HSRP, OSPF

Unanswered Question
Jul 5th, 2007

Hi all,

I have created a VLAN that will house our printers.

The VLAN is served by two c3750 switches running HSRP.

I want to filter traffic on the VLAN interface to allow only a specific network and host to have full access to the VLAN, but allow everyone else to ping.

Ive created an extended IP access list as follows:

ip access-list extended printeraccess

permit ip any

permit ip host any

permit icmp any any

I then apply this with an access map as follows:

vlan access-map printer 10

match ip address printeraccess

action forward

vlan filter printer vlan-list 106

This all works fine, except HSRP is now blocked, and OSPF also.

I add the following line to the access-list to allow HSRP:

permit udp any any eq 1985

After this the HSRP cluster comes back to life, but no other communication is allowed over the VLAN - not even the ICMP.

As soon as I remove this statement again, ICMP and IP access starts working but the HSRP cluster falls over.

I will eventually need to add permit ospf any any. But I wanted to get this sorted first.

Any ideas?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Amit Singh Thu, 07/05/2007 - 10:32


Check, what "show access-list printeraccess " shows you. I would recommend to delete the entire ACL and then rewrite it and then apply to the Vlan access Map.

ip access-list extended printeraccess

permit udp any any eq 1985

permit ospf any any

permit ip any

permit ip host any

permit icmp any any

HTH,Please rate if it does.

-amit singh

misd.network.support Mon, 07/09/2007 - 06:06


Ive tried recreating the Access List several times. The syntax is definitely correct.

As soon as I remove the permit udp any any eq 1985 statement from the Access list everything springs into life. As soon as I add it again, everything is dropped.

Ive tried on swapping the active roles on the HSRP and applying the access list on the other switch too. Exactly the same result.


This Discussion