OSPF broadcast mode w/ inverse-arp

Unanswered Question
Jul 5th, 2007
User Badges:

I am seeing some behavior out of OSPF in non_broadcast mode that I would not expect. I haven't identified any neighbors on any interfaces, yet the spokes are forming full adjacencies with the hub. I do have inverse-arp enabled on my frame switch and I suspect that inverse-arp is 'enabling' this behavior. Can you please explain the what and the why of what I am seeing?


------------------ HUB -----------------

interface Serial1/0

description *** to Frame Switch S5 ***

ip address 172.31.11.4 255.255.255.0

encapsulation frame-relay

no fair-queue


router ospf 1

log-adjacency-changes

network 172.31.11.0 0.0.0.255 area 0


------------------Spoke1----------------

interface Serial0/0

ip address 172.31.11.1 255.255.255.0

encapsulation frame-relay

frame-relay lmi-type cisco

router ospf 1

log-adjacency-changes

network 172.31.11.0 0.0.0.255 area 0

-----------------Spoke2-----------------

interface Serial0/0

ip address 172.31.11.2 255.255.255.0

encapsulation frame-relay

end

router ospf 1

log-adjacency-changes

network 172.31.11.0 0.0.0.255 area 0


spoke2#show ip ospf nei


Neighbor ID Pri State Dead Time Address Interface

172.31.11.4 1 FULL/BDR 00:01:48 172.31.11.4 Serial0/0


spoke2#show ip ospf int

Serial0/0 is up, line protocol is up

Internet Address 172.31.11.2/24, Area 0

Process ID 1, Router ID 172.31.11.2, Network Type NON_BROADCAST, Cost: 64



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Thu, 07/05/2007 - 14:35
User Badges:
  • Green, 3000 points or more

Hi


Just wondering did you have neighbor statements earlier then subsequently removed it. I have seen routers use the cached neighbor info to form ospf adjacency.


HTH


Sundar

jdevoll Thu, 07/05/2007 - 15:56
User Badges:

Actually yes, I did have the neighbor statements listed previously. I'll re-load everything and see if I end up with the same behavior.

sundar.palaniappan Thu, 07/05/2007 - 15:58
User Badges:
  • Green, 3000 points or more

That's what I thought.


Let us know what the outcome is after the reload!!


HTH


Sundar



Edison Ortiz Thu, 07/05/2007 - 16:11
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You don't have to reboot. Issue the


clear ip ospf process



Edison Ortiz Thu, 07/05/2007 - 15:29
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Let's see the 'show frame map' and 'show ip os int bri' command from all routers involved.

Actions

This Discussion