RME problem - Unable to retrieve inventory for 3845 router

Unanswered Question
Jul 5th, 2007
User Badges:

I have a 3845 router for whcih I can't retrieve inventory.


Here is the RME job error...

RICS0001:Internal Error,unable to process the collected data from the device


Here is the IC_Server.log error...

Exception occured in process method while processing: 10.8.0.1 ASA Error -193: Primary key for table 'PhysicalPort' is not unique


Any ideas?

Cheers SteveK.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Thu, 07/05/2007 - 21:20
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Without the whole log, it's impossible to tell for certain, but this looks like CSCse52700. A patch is available by calling the TAC.

stevek1 Sun, 08/24/2008 - 15:17
User Badges:

Hey Joe,

I applied this patch as directed back in July 2007 but we still get these errors from time to time when we replace a device.


For example, on the weekend we replaced 2 old 6513s with new 6513s - basically the same configs, just an 3 year cycle upgrade (newer Sup, IOS etc). I found that 1 of them is fine in RME, however the other 1 has the RICS0001 error as reported for other device at the start of this thread. One thing different about the failing 1 is that I have added an ACE module to the chassis.


Should I still be getting this problem after the patch was applied?


Cheers, SteveK.

Joe Clarke Sun, 08/24/2008 - 19:23
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There are two other bugs which may account for this: CSCsm97530 and CSCso54489. A consolidated patch with both fixes is available from TAC for RME 4.0.6 and 4.1.1. The bugs are fixed in 4.2.

Actions

This Discussion