java.sql.timestamp variable type not available

Unanswered Question
Jul 6th, 2007

Problem Details: I am trying to return a value from a DB" database which

the DB Get step believes is a java.sql.timestamp type.

I have tried creating a variable of this type; there are none as default in the

drop down list and as per the script editor getting started guide, I have tried

entering the fully qualified java type (java.sql.timestamp) and the script

editor just rejects it, yet for example, if i enter java.math.BigDecimal, it

automatically converts the type to "BigDecimal" as soon as i move

away from this.

I see from documentation for CRS 2.2, this variable type was available. Has it been removed? If so, is there another way around this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
raynorris Fri, 07/06/2007 - 05:50

The problem was that java is case sensitive and if I enter java.sql.Timestamp (capital T) instead of java.sql.timestamp, it works fine.

Always a simple answer!


This Discussion