2950's and 2940's

Unanswered Question
Jul 6th, 2007

Occasionally some of my 2940's or 2950's will become unmanageable. That is layer 2 traffic passes through it but I can no longer telnet, ping, or anything the switch itself. Has anyone else had this problem? I thought it was maybe a memory issue.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Amit Singh Fri, 07/06/2007 - 07:48

Have you monitor the memory utilization before or after this happened. What do you do when this problem happens. What is the IOS running on the switches. Did you check the switch logs for some errors on this.

It could be related to some software issues as well. Have you tried upgrading the IOS on thye switches.

-amit singh

jlhainy Fri, 07/06/2007 - 19:57

I usually had this problem after imaging computers. After configuring igmp snooping and getting pim set up on my router, I have not had this problem since. the only way for me to recover was to reboot the switch.

berndziller Wed, 09/26/2007 - 21:51

I have the same problem with my 2940 Switches.

The switches become unresponsive to telnet/ping, but still forward all traffic.

The logs didn't contain any errors. (Only infrequent interface up/downs, due to PCs reconnecting)

Our 2940 switches are running for over a year in low traffic areas of our network. The failing switches still got more traffic than the rest of the 2940s.

IOS is 12.1(22)EA4.

How do I monitor memory utilization?

How can I obtain a new IOS?

glen.grant Thu, 09/27/2007 - 04:03

Latest release is 12.1.22.EA10a for 2940's . We have a lot of 2950's and have never seen that problem , think 12.1.22 ea10 is the latest for those too.

mraful Thu, 09/27/2007 - 05:54

It is limited to just a few of these devices. I have removed one 2940 permanently. That definitely fixes that problem.

mraful Thu, 09/27/2007 - 05:52

Use the show mem command and look under Largest(b), which is the largest amount of contiguous bytes available. Check to see if that number is droppong. As far as new IOS, if you have smartnet you can download a new image from CCO.

mraful Thu, 09/27/2007 - 05:30

Yes, I have tried upgrading the IOS but the problem persisted. Fortunately, I have begun migrating away from these switches.

l.mourits Thu, 09/27/2007 - 04:32

I've seen this happen on several switches as well. In my case it happened because of a process that ran to long in CPU which itself turned out to be a bug (which only showed under mediate or high traffic patterns when multiple vlan interfaces where configured).

Typical recommendation here is to check your current version's release notes to see if there are any caveats and upgrade the switch to the latest release.




This Discussion