SIP Day

Unanswered Question
Jul 7th, 2007

Hi,

couple of SIP questions:

1) I tried to converte an SCCP to SIP with no sucess;

phone 7960; sccp firmware 8.0(4) and boot load PC0303010200;

SIP i tried both versions P0S3-07-5-00; P0S3-08-6-00

i followed the chapter in the admin guide about how to do the conversation also i cheked tac notes

SIPDefaultGeneric.cnf and SIPConfigGeneric.cnf; i only have 5 files with zip for the sip firmware

2) Does ip communicator works with CME sip config version 4.0

3) In case i want to run for internal use CME with SIP (IP phone as well) do i need anything or just SIP firmware for the IP phones.

Good day

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
Paolo Bevilacqua Sat, 07/07/2007 - 08:37

First of all, I suggest you keep your phones as SCCP because generally are easier to administer and have more features. Now:

1. The conversion works. Where is failing for you ?

2. CME can run simultaneously SIP and SCCP phones, hence IPCP will always work.

3. Nothing else.

Hope this helps, please rate post if it does!

twissam Sat, 07/07/2007 - 08:44

the IP phone (currently SCCP) giving XMLdefault.. not found. it is like it is still looking for the SCCP and not for SIP.

the following files are in flash:

OS79XX.TXT

P0S3-07-5-00.bin

P0S3-07-5-00.loads

P0S3-07-5-00.sb2

and under voice register globale i pointed to the sip load

load 7960-7940 P003-07-5-00

....

Good day

Paolo Bevilacqua Sat, 07/07/2007 - 09:17

Hi,

1. Verify that all the FW files have been configured with "tftp-server "

2. Configure a "voice register pool" with correct MAC, type and dn number.

3. Under "voice register global" do "create profile".

4. Verify that the correct cnf.xml file has been generated with: "show voice register tftp-bind" and "more ".

The phone should upgrade and register on the next boot.

Hope this helps, please rate post if it does!

twissam Sat, 07/07/2007 - 09:21

I will try them and come back to you within 30 min aprox

thanks for your help even in we, you should get doubled points ;-)

Good day

twissam Sat, 07/07/2007 - 10:07

same thing, but now i am not getting anyting on the IP phone, only configuring IP, looking for CM list

attached are some info i got for you

just wondering as the you are sure that all the 7960 could be converted to sip.

one more thing regarding CIPC, i was wonderig if it can be configured as voice register not as ephone. as i could not find the type with v4.0 in CME voice register.

thanks in advance and good day.

Attachment: 
twissam Sat, 07/07/2007 - 10:20

i have just enabled telephony-service to see what is happening:

also when i unplug the ip phone and plug it again it give no load found!!!

vg-sip(config)#telephony-service

vg-sip(config-telephony)#exit

vg-sip(config)#^Z

vg-sip#show telephony-service tftp-bindings

vg-sip#show telephony-service tftp-bindings

tftp-server system:/its/SEPDEFAULT.cnf

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf

tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP001A2F53C711.cnf.xml

Paolo Bevilacqua Sat, 07/07/2007 - 10:42

Hello,

please remove "ephone" for the MAC you're converting. If you have removed it already,reboot the router and check there is no entry for the MAC when doing "show telephony-service tftp-bindings"

Regarding the IP communicator, it supports SCCP only, so you will always configure it under "ephone" and never under "voice register pool".

twissam Sat, 07/07/2007 - 10:48

vg-sip#show telephony-service ephone

Number of Configured ephones 0 (Registered 0)

thanks a lot for your help

Good day

Paolo Bevilacqua Sat, 07/07/2007 - 10:54

The thing as you have seen above, it seems the system retains the tftp-bindings for SCCP even after removing the ephone, so you should reboot the router.

After that the phone should get the correct cnf.xml with load definition for SIP and upgrade.

twissam Sat, 07/07/2007 - 11:07

i did the reoot and inded the telephony-service binding disappeared and we are back to the beggining.

on the IP phone it is lookingfor the XMLDefault.

any way it is not a big issue i would try with another IP phone.

Thanks a lot for your help

Good day

twissam Sat, 07/07/2007 - 11:11

Working.

I took a reboot for the IP phone as well after the router.

that was it.

thanks a lot for your assisstant.

Good one.

Good day

Paolo Bevilacqua Sat, 07/07/2007 - 11:13

Glad to know it worked. The phones at time can be a bit stubborn, and it takes patience.

Thanks for the nice rating and good luck!

Actions

This Discussion