Trouble With Routing on One Router

Unanswered Question
Jul 7th, 2007

Hi, I am a new user and am studying for my CCNA at this time. I have two routers, bought from e-bay. 1 - 2505 and 1 - 2507.

My configuration is this;

2505:

Ethernet 0 - 172.16.0.99 255.255.0.0

Serial 0 - 192.168.1.3 255.255.255.0

Systems connected on the 172.16 subnet to the hub ports

2507:

Ethernet 0 - 10.0.0.2 255.0.0.0

Serial 1 - 192.168.1.1 255.255.255.0

Systems on the 10. subnet connected to hub ports

Now, I can ping all 172.16 hosts from 2505. I can also ping all 10. hosts from 2505 and clients on that host.

From 2507, I can ping 172.16.0.99 on 2505 which is the ethernet 0 interface but I cannot ping anything beyond that.

I have tried RIP, EIGRP and static routes but I cannot route beyond the 2505 router for some reason.

Am I missing something simple here?

Thanks

Gerry

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
sundar.palaniappan Sat, 07/07/2007 - 08:48

Gerry,

What's the default gateway set to for the hosts on the 172.16 network. Their gateway should be set to 172.16.0.99 and make sure the subnet mask is set to /16 bits.

HTH

Sundar

gerryaobrien Sat, 07/07/2007 - 09:19

Subnet mask is set at 16 bits as indicated by the 255.255.0.0 SN shown in the post.

My routing problem is going in the opposite direction to what you are thinking. The hosts on the 172.16 subnet can successfully ping the hosts on the 10. subnet.

The hosts on the 10. subnet cannot ping anything on the 172.16 subnet.

The hosts on the 10. subnet have their default gateway set to 10.0.0.1 which is the IP address of Ethernet 0 on that router.

Also, they can ping 172.16.0.99 but nothing beyond that. It's like the router is not routing anything. Although the router itself can ping hosts on the 172.16 subnet, it just won't let the other router reach hosts on the 172.16 subnet.

When I ping from the 10. router, I get the ..... and from any host on the 10. subnet, I don't get Destination Unreachable, I simply get Request timed out.

Thanks

sundar.palaniappan Sat, 07/07/2007 - 09:26

In your original post you said the IP of E0 on 2507 is 10.0.0.2 whereas the last posting you said the hosts are configured with a gateway address of 10.0.0.1 which one is correct?

If you are still having problems can you post the full sanititized configuration of both routers

gerryaobrien Sat, 07/07/2007 - 11:28

Sorry, my OP was wrong. E0 on 2507 is 10.0.0.1.

How best would you like the config posted?

Thanks

Gerry

sundar.palaniappan Sat, 07/07/2007 - 12:16

Remove any passwords and post the entire configuration.

It's a little odd that you are able to ping the 10. hosts from 172.16 net but not the other way around. Given the fact you are able to ping the gateway address 172.16.0.99 but nothing beyond it from the 2507 and the 10. net the first thing to comes my mind is a possible incorrect gateway setting for the hosts but you have confirmed it's set to the correct address of 172.16.0.99.

Can you make sure another host on the 172.16 network isn't duplicating gateway's address of 172.16.0.99.

HTH

Sundar

gerryaobrien Sat, 07/07/2007 - 12:47

I had my IP's backwards for the serial interfaces in my OP as well but that shouldn't make a difference as they routers can see each other.

Here is the running-config for both routers;

2507 Config

Current configuration : 1339 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxx

!

enable password

!

!

!

!

!

ip subnet-zero

!

!

!

!

hub ether 0 1

link-test

auto-polarity

!

hub ether 0 2

link-test

auto-polarity

!

hub ether 0 3

link-test

auto-polarity

!

hub ether 0 4

link-test

auto-polarity

!

hub ether 0 5

link-test

auto-polarity

!

hub ether 0 6

link-test

auto-polarity

!

hub ether 0 7

link-test

auto-polarity

!

hub ether 0 8

link-test

auto-polarity

!

hub ether 0 9

link-test

auto-polarity

!

hub ether 0 10

link-test

auto-polarity

!

hub ether 0 11

link-test

auto-polarity

!

hub ether 0 12

link-test

auto-polarity

!

hub ether 0 13

link-test

auto-polarity

!

hub ether 0 14

link-test

auto-polarity

!

hub ether 0 15

link-test

auto-polarity

!

hub ether 0 16

link-test

auto-polarity

!

interface Ethernet0

ip address 10.0.0.1 255.0.0.0

!

interface Serial0

ip address 192.168.1.3 255.255.255.0

!

interface Serial1

no ip address

shutdown

!

router eigrp 2

network 10.0.0.0

network 192.168.1.0

auto-summary

no eigrp log-neighbor-changes

!

router rip

network 10.0.0.0

network 192.168.1.0

!

no ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0

password

login

line vty 1 4

login

!

end

2505 Config

Current configuration : 1128 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Rascals2505

!

enable secret xxx

enable password

!

!

!

!

!

ip subnet-zero

!

!

!

!

hub ether 0 1

link-test

auto-polarity

!

hub ether 0 2

link-test

auto-polarity

!

hub ether 0 3

link-test

auto-polarity

!

hub ether 0 4

link-test

auto-polarity

!

hub ether 0 5

link-test

auto-polarity

!

hub ether 0 6

link-test

auto-polarity

!

hub ether 0 7

link-test

auto-polarity

!

hub ether 0 8

link-test

auto-polarity

!

interface Ethernet0

ip address 172.16.0.99 255.255.0.0

!

interface Serial0

no ip address

loopback

shutdown

!

interface Serial1

ip address 192.168.1.1 255.255.255.0

clockrate 125000

!

router eigrp 1

network 172.16.0.0

network 192.168.1.0

auto-summary

no eigrp log-neighbor-changes

!

router rip

network 172.16.0.0

network 192.168.1.0

!

ip classless

ip http server

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

sundar.palaniappan Sat, 07/07/2007 - 14:19

There isn't anything configuration that should be causing the problem you are experiencing. Can you configure the following two ACLs and apply it on e0 of 2505. Then initiate a ping from the 10. net to a host on the 172.16 net. Get the output of 'show ip access-list' and let us see whether we are seeing matches on the ACLs. This could help us isolate the problem.

access-list 100 permit ip 10.0.0.0 0.255.255.255 172.16.0.0 0.0.255.255

access-list 100 permit ip any any

access-list 101 permit ip 172.16.0.0 0.0.255.255 10.0.0.0 0.255.255.255

access-list 101 permit ip any any

int e0

ip access-group 100 out

ip access-group 101 in

gerryaobrien Sat, 07/07/2007 - 15:40

So, now you understand my puzzled presence. :-)

Initially, when I bought these routers off e-bay, they had access lists and configurations already. I completely erased the configurations so that I was starting with a clean config. As a matter of fact, the 2507 came with a password I had to reset and an older versions of the IOS. So, once I had the 2505 at a clean config, I made a backup of the IOS and then installed that on the 2507.

So, there were no acls blocking or allowing anything during my configurations.

I have applied these acls now and there is no difference. Here is the output of the show ip access-list;

Rascals2505>show ip access-list

Extended IP access list 100

permit ip 10.0.0.0 0.255.255.255 172.16.0.0 0.0.255.255 (4 matches)

Extended IP access list 101

permit ip 172.16.0.0 0.0.255.255 10.0.0.0 0.255.255.255

permit ip any any (2417 matches)

Rascals2505>

gerryaobrien Sat, 07/07/2007 - 16:17

Ok, so to add to the strangeness, it is now working. I am able to ping 172.16 hosts from 10. hosts.

I have to say that I have never been this confused in my life.

I understand IP addressing, routing and subnetting quite well and could not understand why this wasn't working. Being new to Cisco routers, I wondered if it was something I was missing on the platform.

At any rate, I am routing now for whatever unknown reason.

Thanks for your help along the way and the sanity check.

sundar.palaniappan Sat, 07/07/2007 - 17:43

These types of unexplainable behavior is what keeps this field interesting :-)

Anyway,the previous posting shows access list 100 with packets leaving the 2505 but access list 101 doesn't show any ICMP echo replies from the hosts on the 172.16 net coming back into the router. This indicates the problem is on the LAN beyond the 2505 and may be on the hosts themselves. The only way to know for sure why it wasn't working is to do a sniffer capture when the problem is happening.

Well anyway glad to hear it's working now!!

Let us know if the problem resurfaces again we shall get to the bottom of the problem.

HTH

Sundar

gerryaobrien Sat, 07/07/2007 - 18:07

I love a challenge too. What I hate is when you look at something that you know in all your experience should work, but doesn't. It definitely keeps it interesting and that's what I love about it. :-)

Now, I just need to figure out how to get those on the 10. network to access the Internet over that router connection. I may be pushing it here.

I have one of hub ports from 2505 plugged into a 2924XL switch which is connected to a Linksys router connected to my DSL modem.

Is that a requirement for using static routes? Is there a way to assign a default gateway to e0?

Thanks

Gerry

sundar.palaniappan Sat, 07/07/2007 - 19:48

Add a default route to the 2505 to point to the Linksys router LAN interface address (gateway). Configure 2505 to NAT the 10. network to 172.16 address. Linksys would then NAT (PAT) 172.16 net using the public IP assigned by your ISP for Internet bound traffic.

HTH

Sundar

Actions

This Discussion