HELP: Configuring ISIS on a CLNS environment

Unanswered Question
Jul 9th, 2007
User Badges:

Dear All,


I have a 2610 router that is running OSPF and ISIS, I want to connect the router to an SDH NE (Alcatel) which is not running IP. However it has an NSAP address. Is there any special configuration on the router's interface connected to the NE?

I've already configured the interface to suppport clns. Below is the configuration that i made on the router.


Clns routing

!

Router isis

net 39.682F.8000.0000.0000.0001.0003.3333.3333.3333.00

is-type level-1-2

!interface FastEthernet0/0

ip address 10.190.17.90 255.255.255.248

ip router isis

duplex auto

speed auto

clns router isis

isis circuit-type level-1

!

interface Serial0/1

ip address 10.190.30.6 255.255.255.252

ip router isis

clockrate 64000

clns router isis

isis circuit-type level-2-only


I tried to ping the node using ping clns 39.682F.8000.0000.0000.0001.0003.0020.6001.4314.1D but it failed, however when I ping the neighbor router (3725) it was connecting so i assume that isis is ok between the two routers.


I think I am missing something...

Can anybody help me out.


Thanks




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chrihussey Mon, 07/09/2007 - 06:09
User Badges:
  • Silver, 250 points or more

I'm not sure and this is just a guess, but have you tried adding "clns enable" to the interface facing the Alcatel system?

wireheadz Mon, 07/09/2007 - 22:32
User Badges:

tnx for your reply. I've already done that and it was not working. so, I removed it. Its really odd coz when i tried to view the neighbors(show clns neighbors) the system id of the NE is actually displayed and its state is up. However when i tried to ping (ping clns XX.XXXX....XX) the NE's NSAP address, it was not reachable. Below are some show commands that Ive done on the router.


AREA3ECCM#sh clns neig


System Id Interface SNPA State Holdtime Type Protocol

Area1MAIN Se0/1 *HDLC* Up 23 L2 IS-IS

0020.6001.4314 Fa0/0 0020.6001.4314 Up 163 IS ES-IS

AREA3ECCM#sh isis route


IS-IS Level-1 Routing Table - version 97

System Id Next-Hop Interface SNPA Metric State

0020.6001.4314 0020.6001.4314 Fa0/0 0020.6001.4314 10 Up

AREA3ECCM --

AREA3ECCM#sh clns protocol


IS-IS Router:

System Id: 3333.3333.3333.00 IS-Type: level-1-2

Manual area address(es):

39.682f.8000.0000.0000.0001.0003

Routing for area address(es):

39.682f.8000.0000.0000.0001.0003

Interfaces supported by IS-IS:

FastEthernet0/0 - OSI - IP

Serial0/0 - OSI - IP

Serial0/1 - OSI - IP


Note: The Alcatel NE is connected via Fa0/0

interface.


chrihussey Tue, 07/10/2007 - 08:44
User Badges:
  • Silver, 250 points or more

The only thing I can suggest is to remove all the ISIS configuration from the F0/0 interface and add the "clns enable" and then try it. Below is the explanation:


"clns enable" - You also must enable ISO CLNS for each interface you want to pass ISO CLNS packet traffic to end systems, but for which you do not want to perform any dynamic routing on the interface.


Unfortunately that's probably the best I can offer. Also, just in case you don't have this, I've attached a CLNS config PDF.




Attachment: 

Actions

This Discussion