PPP Authentication does not work...

Unanswered Question
Jul 9th, 2007

Hi all,

I am practising PPP authentication with PAP & CHAP on dynamips/dynagen using 2 router with serial int config. It just does'nt work. Both the books (Todd & cisco press) mention just 3 steps viz. encap ppp, ppp auth pap or chap, username *** pass ***. I even tried this on real routers in a lab. It does'nt work either.

Are there any more commands to make it work?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
junshah22 Mon, 07/09/2007 - 03:49


The username command is case sensitive in which you define remote router's hostname as username and password must be same on both routers and case sensitive.

If both books Todd % Cisco mentioned it so it must work.



glengregory Mon, 07/09/2007 - 08:06

You think I don't know this already? Going by the book and I tried some extra commands like "ppp pap sent-username ** password **". Still does'nt work. When debugging enabled, nothing is shown. Weird!

This "simple" problem has been bugging me for along time. Hope someone on this forum has an explanation for this.



etienne.basset Mon, 07/09/2007 - 23:18


could you post your conf?

hostname R1

username R2 pass toto

int s1/0

encaps ppp

ppp aut chap


hostname R2

username R1 pass toto

int s1/0

encaps ppp

ppp aut chap

glengregory Tue, 07/10/2007 - 02:20


Exactly the same as you have shown...

Just try it out on dynagen or real routers.



etienne.basset Tue, 07/10/2007 - 03:47


i did :) and it "obviously" works.

the only think i can think of is a "hidden" whitespace....

try again from scratch



glengregory Tue, 07/10/2007 - 21:07


Tried again last night and CHAP worked! But PAP never works.

Even if you enter the "authen" command on R1, it works. There's no need to give it on R2. I then tried to re-create the sequence of steps when it did NOT work:-

1] Both R1 & R2 s 0/0 are with HDLC.

2] On R1, enter the "username" command, enable PPP and "authen" command.

3] did the same on R2.

Sequence of steps when it did work:-

1] Both R1 & R2 s 0/0 are with HDLC.

2] Encap PPP on both R1 & R2. Link up.

3] On R1, did "authen" command. link shows up. debug shows 3-way challenge, response, success.

4] did the same on R2. link shows up.

Now, for PAP.

1] Remove "authen" command on both. link shows up.

2] add "ppp auth pap" on both. both link shows down & remains that way. debug shows no activity. weird!

Now. for the best part....

3] Remove "authen" command on both. both link shows down & remains that way. Why?

There's something very weird about this "simple" PPP config task. I will try it again...




This Discussion