configuring Cisco router as a DHCP server for multiple IP subnets

Unanswered Question
Jul 9th, 2007
User Badges:

HI all,


I need to configure Cisco router 2600 series as a DHCP server for multiple IP subnets(6 subnets). Which is not direclty connected to the router.


configuring multiple IP subnets is possible or not ?



is it possible to configure like this


EX:


!

no ip domain lookup

ip dhcp excluded-address 10.10.1.100 10.10.1.254

ip dhcp excluded-address 10.11.1.100 10.11.1.254

ip dhcp excluded-address 192.168.1.100 192.168.1.254

!

ip dhcp pool net1

network 10.10.1.0 255.255.255.0

dns-server 10.10.1.100

netbios-name-server 10.10.1.100

default-router 10.10.1.254

domain-name pingo.com

!

ip dhcp pool net10

network 10.11.1.0 255.255.255.0

dns-server 10.11.1.100

netbios-name-server 10.11.1.100

default-router 10.11.1.254

domain-name pingo.com

!

ip dhcp pool net100

network 192.168.1.0 255.255.255.0

dns-server 192.168.1.100

netbios-name-server 192.168.1.100

default-router 192.168.1.254

domain-name pingo.com

!


===

Assume that router interfaces are holding different subnets . machines are getting IP add through IP helper address

via WAN Network


Please post your suggestions

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
guruprasadr Mon, 07/09/2007 - 01:50
User Badges:
  • Gold, 750 points or more

Hello Gopikrish, [Pls Rate if Helps]


Only a few steps required:


ip dhcp pool POOLNAME

network "Subnet address" "Mask"

default-router "GW address"


Info: you need an interface which is configured with the GW address.



Please review the following Link for Detailed description in Configuring the DHCP Server:


http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca75c.html



Pls Rate if HELPS


Best Regards,


Guru Prasad R

gopikrish Mon, 07/09/2007 - 03:31
User Badges:

Hi Guruprasad,


Thanks for the information.You mean to say that the router will asssign the correct ip address based on the gateway IP address in the DHCPOFFER message.


So configuring multiple DHCP pools will not be a problem right!!


Thanks again


tx

Krishna

guruprasadr Mon, 07/09/2007 - 03:57
User Badges:
  • Gold, 750 points or more

HI GopiKrish, [Pls Rate if Helps]


No Problem please go ahead.


Unless & Until you have a Unique Gateway for each Pool on the same Subnet.



Pls Rate if HELPS


Best Regards,


Guru Prasad R

Fraser Reid Mon, 07/09/2007 - 05:04
User Badges:

you could configure a dot1q trunk port on the router to a switch and use each VLAN for the separation of each subnet you want to use with DHCP then on the router give each VLAN an IP address - this way you have complete separation and this is what you need for multiple DHCP on 1 router - Separate Gateways (ie default-router) for each DHCP pool.


Please rate if it helps :-)

mohammedmahmoud Tue, 07/10/2007 - 02:58
User Badges:
  • Green, 3000 points or more

Hi,


I agree with Fraser's suggestion its a nice solution.


HTH,

Mohammed Mahmoud.

Fraser Reid Tue, 07/10/2007 - 03:16
User Badges:

example config would be like this


interface FastEthernet0/0

description trunk port

no ip address

duplex auto

speed 100

!

interface FastEthernet0/0.1

encapsulation dot1Q 1

ip address 10.10.1.254 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.11.1.254 255.255.255.0

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.1.254 255.255.255.0

!



Hope this helps :-)


Please rate my posts

gopikrish Thu, 07/12/2007 - 04:08
User Badges:

Hi Guys,


Thanks for all your help.the information posted is very informative for me.


i followed the instrctions given by Guruprasad

(that suits my requirement)


Frazreid also given a good solution


Thanks,

Krishna

Actions

This Discussion