7960 SIP Registration Rejected

Unanswered Question
Jul 9th, 2007

Hi, I'm running Callmanager 5.0(4)

I can autoregister and manually add 7960's as SCCP phones with no problem.

When I try to autoregister or add them as SIP phones I receive a 'Registration Rejected' error.

I can register 3rd party SIP phones with no problems.

I'm not associating any users or digest authentication on the 7960's, I don't think this should be necessary?

The Callmanager has been installed with a default configuration.

Does anyone know what is causing this?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sheeptest Mon, 07/09/2007 - 14:45

I finally figured out the problem with the phones when I was waiting for my train last night- it turned out it wasn?t actually anything to do with SIP. The way things had gone led me down that path and I needed to get away from the office before I could think straight about it.

I?d added the phones as SCCP with autoregistration. I then tried to add a SIP phone manually but this failed. It took the SIP firmware okay but was coming up as ?Registration Rejected.? I thought I had maybe misconfigured authentication or something so the next thing I tried was to autoregister the phones with SIP. SIP autoregistration came up as ?Registration Rejected? as well though. This had me thinking that there was something wrong with SIP phones registering, maybe a configuration issue or missing parameter. It was something a lot more simple though- I?d configured the autoregistration range for existing phones and the directory numbers had been taken when the phones registered with SCCP. When I deleted the SCCP phones their directory numbers were still in the system, so there were no numbers available when they tried to autoregister with SIP.

When I came in this morning I deleted the DN?s from the system and SIP autoregistration worked fine. I also added a SIP phone manually this morning. I?m not sure why I couldn?t do that last night as I double-checked the MAC address was correct. I?m still not sure what the problem was there but never mind everything?s working fine now.

Actions

This Discussion