ip unnumbered and ip nat

Unanswered Question

Hi All,


I am setting up an internet T1 and have been told to use the ip unnumbered command as they do not provide /30 serial addresses. I also have to do nat behind this link. Normally I would put my ip nat inside on the ethernet int and the ip nat outside on the serial int. Do I follow those same rules with this setup as well? if not, what is the proper way to do this?


TIA,


R

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 07/09/2007 - 09:25
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


They will have top do the NAT for you then unless they have allocated you some useable public IP addresses for the Internet.


If they haven't i would speak to them as without an address there is little you can do.


HTH


Jon

No I actually do have several usable addresses. I am just wondering if I can do somethign like the following:


interface FastEthernet0/0

ip address 255.255.255.248

ip nat inside

duplex auto

speed auto

!

!

interface Serial0/0/0:1

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Serial0/0/0:1.1 point-to-point

ip unnumbered FastEthernet0/0

ip nat outside

frame-relay interface-dlci 500 IETF

!

!

ip nat inside source static

ip nat inside source static

Richard Burts Mon, 07/09/2007 - 11:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Ro


I have had this situation at a customer site where they assign public IP from the provider on the LAN interface and ip unnumbered on the outbound serial. They do ip nat inside on the LAN interface (as you are asking) and ip nat outside on the serial subinterface. It works well for them.


HTH


Rick

Actions

This Discussion