WCS and SNMPv3 controller

Unanswered Question
Jul 10th, 2007

Hi,

does anyone had troubles adding controller to WCS 4.1 using SNMPv3 ?

I've the following devices:

- wlc2006 4.0.217

- wcs 4.1.91

On the wlc i've enabled ( as is by default ) SNMPv3 and I created an SNMPv3 user but when i try to add to WCS I get error ( see down ). If I use SNMPv2c all works fine.

Any suggest ?

regards and many thanks

Luigi

(cl068001) >Tue Jul 10 10:58:44 2007: SNMPD: Packet from: 10.46.250.57:1503, in_packet_len = 134

Tue Jul 10 10:58:44 2007: SNMPD: calling srDoSnmp.

Tue Jul 10 10:58:44 2007: unknown user names

Tue Jul 10 10:58:44 2007: SNMPD: Sending SNMP packet to 10.46.250.57:1503, out_packet_len = 113

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
sbilgi Mon, 07/16/2007 - 12:33

Check the community string of the contoller and WCS.

LUIGI PIETRONAVE Wed, 07/18/2007 - 04:05

hi,

thanks for the reply, but the community is the same; adding controller with SNMPv2c all is working fine.

I'll make some other tests,

best regards

Luigi

ericgarnel Wed, 07/18/2007 - 05:12

Are you enabling the read community or write community with snmpv3. And have you added the snmpv3 users on the controllers as well with the same auth proto & privacy proto?

the defaults are hmac-md5 & des for user 'default' with read/write access

LUIGI PIETRONAVE Tue, 07/31/2007 - 04:13

Hi,many thanks for the reply but i don't understand.

a) where I've to enable the community with SNMPv3 ? In the wcs when i import controller with SNMPv3 there is not community to specify and on the controller the community are only for SNMPv1 and SNMPv2c. An i right ?

b) I've the same users/privacy on the controller and WCS ( i tried to remove them several time, thinking about a mistyping ).

Regards

Luigi

pmccubbin Wed, 08/01/2007 - 11:09

To elaborate on what Eric said:

On the controller go to

Management-->SNMP-->SNMP v3 Users

You can use the defaults or create a new user by clicking on the New button on the right hand side of the page.

On the WCS when you add a new controller you will be shown the SNMP parameters. Select Version 3 and enter the same parameters you used on the controller.

Hope this helps.

LUIGI PIETRONAVE Wed, 08/01/2007 - 23:37

Hi,

thanks for the reply but is what've done.

I tried several times thinking about some mismatch between username/password/encrypt on the controller and on the wcs, but no way...

At this time i'm importing the controller with SNMPv2

regards

Luigi

milan_simcik Thu, 01/03/2008 - 11:44

Hi Luigi,

It seems that I have the same problem. I would like to ask you if you solved this problem successfuly.

I am going crazy because I have three WLC 4402 running 4.2.61 and WCS 4.2.62 and only ONE WLC has the same symptoms as you desribe earlier. The remaining two WLC work properly.

Thanks you for an idea.

Milan

tkhan Mon, 01/07/2008 - 06:19

I've had this problem for a while, through many releases. I'm not sure if Cisco has identified it as a bug or not but my workaround is to use the "default" SNMPv3 user to add the controller, add a separate SNMPv3 user, then switch WCS to use the new SNMPV3 user.

koksm Mon, 01/14/2008 - 04:19

I experienced exactly the same thing, with the same versions.

2 WLC's, the first one connected without any problems on SNMPv3c, the second one wouldn't connect.

After a while i first connected it on version 2, and directly after that on version 3. That worked in our case.

rduke Wed, 01/09/2008 - 11:31

FYI,

I had to reboot a couple of my controllers after enabling v3. It seemed to occur after I disabled v1 and v2. That did not always occur, but as I recall I had 2 out of 7 that would not work until rebooting.

Randy

dennischolmes Mon, 06/16/2008 - 09:47

Two things to look for. First, snmp community strings are case sensitive in the controllers. Make sure all capital letters are in correct places or you will get a failure. Second, see below instructions for fragmented file sizes.

If you are adding a controller into WCS across a GRE link using IPsec or a lower MTU link with multiple fragments, you may need to adjust the MaxVar Binds PerPDU. If it is set too high, the controller may fail to be added into WCS. To adjust the MaxVarBindsPerPDU setting, do the following: 1) Stop WCS. 2) Go to the location of the the Open SnmpParameters.properties file on the server that is running WCS. 3) Edit MaxVarBindsPerPDU to 50 or lower. 4) Restart WCS.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode