Switchover from Frame-Relay to dedicated T1

Unanswered Question
Jul 10th, 2007

Hello all,

New to the forums and fairly new to working with Cisco routers.

We have a spoke-and-hub setup with our remote offices where they connect to our main office for all of their needs, including internet access. Currently, one office is on a Frame-Relay circuit and our provider has setup a dedicated T1 to connect back to here to replace it. Everything is in place and tested from the providers end.

Please see the attached file, in the top half, for the original interface configuration.

If you need more of the config file, please let me know. The office I'm concerned with is "remote office 5"

We tried to upload a new config file with the new interface setup, thinking this would work. Please see the second half of the attached file for this setup.

I was not able to make the connection between the 2 offices and reverted back to

the original configuration.

Any help would be appreciated. I did not change IP addresses or any of the firewall

configuration.

Thank you,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 07/10/2007 - 07:22

Jeff

Your issue is that HDLC does not support subinterfaces. To produce a working config remove the subinterface that you attempted for office 5 and put these lines:

ip address 10.1.1.17 255.255.255.252

ip nat inside

ip virtual-reassembly

under interface Serial0/1/1:0

HTH

Rick

jehrmann1 Tue, 07/10/2007 - 08:10

Thank you for the fast reply. I will try out the new configuration tonight and post back tomorrow with results.

jehrmann1 Thu, 07/12/2007 - 08:14

Rick,

We're actually testing this this afternoon, so no results yet.

One question about the router on the other side of this, a cisco 1800 series. Would we need to change anything on this side to accept the new connection?

Thanks,

Jeff

Richard Burts Thu, 07/12/2007 - 08:29

Jeff

If the other side 1800 is configured for Frame Relay and it will be changing to HDLC (to match the change at your end) then yes you will need to make changes on the 1800 similar to the changes on your end.

HTH

Rick

jehrmann1 Thu, 07/12/2007 - 10:59

If the current setup is like this:

interface Serial0/0/0

no ip address

encapsulation frame-relay

no fair-queue

service-module t1 timeslots 1-8

!

interface Serial0/0/0.105 point-to-point

ip address 10.1.1.18 255.255.255.252

frame-relay interface-dlci 100

I would then:

1 - delete the subinterface

2 - edit the interface to show:

interface Serial0/0/0

ip address 10.1.1.18 255.255.255.252

no fair-queue

service-module t1 timeslots 1-8

Does this seem correct?

Again, thank you for your help!!

Richard Burts Thu, 07/12/2007 - 11:09

Jeff

The remote appears to have a partial T1 access link for Frame Relay (512 Kb). If the replacement is also going to be the same partial T1 access as an HDLC link then your config looks good.

However in my experience with point to point HDLC connections the access speed is usually the same at both ends (not partial T1 at one end and full T1 at the other end). With encapsulations like Frame Relay it is common to have the remote end on a lower speed connection than HQ, but not for HDLC. Perhaps you can check with the provider and they can verify what speed link they are providing at the remote.

One other thing to note: you can do "no interface Serial0/0/0.105" to delete the subinterface. And if you do show run you will not see it. But it is not fully gone away. If you do show ip interface brief you will still see the subinterface. It will show up in some commands until the router is reloaded. This is a normal behavior of IOS.

HTH

Rick

jehrmann1 Thu, 07/12/2007 - 11:21

It is currently a frame relay that is being replaced by a full, dedicated T1 so the speed is the same at both ends.

Should I take out any of the following:

no fair-queue

service-module t1 timeslots 1-8

jehrmann1 Thu, 07/12/2007 - 12:21

So the following config should look good:

Main Office: (full T1)

interface Serial0/1/1:0

description T1 Connection to Remote

ip address 10.1.1.17 255.255.255.252

ip nat inside

ip virtual-reassembly

Remote Office: (Full T1)

interface Serial0/0/0

description T1 Connection to Main Office

ip address 10.1.1.18 255.255.255.252

no fair-queue

service-module t1 timeslots 1-8

Sorry to have so many questions. Still learning, but you've been great, thank you! I'm about to test this in a few minutes, so we'll see what happens!

Richard Burts Thu, 07/12/2007 - 12:34

Jeff

The command service-module t1 timeslots 1-8 tells the router that it is a partial T1. I would either take it out or I would change it to service-module t1 timeslots 1-24.

HTH

Rick

jehrmann1 Thu, 07/12/2007 - 13:55

Hi Rick,

Thanks for all of your help. This, unfortunately did not work. I don't know what is going on exactly. Well, tried to take care of this myself, but time to hire a professional.

Thanks again,

Richard Burts Thu, 07/12/2007 - 17:32

Jeff

I am sorry that our advice was not sufficient to help get it to work. I do understand that sometimes it is just time to bring in someone who has experience and expertise to get things done quickly and smoothly (especially since I am one of those consultants). I hope that whoever you bring in will be able to explain to you what was involved and that you will learn from that experience.

HTH

Rick

Actions

This Discussion