Host LACP on a 6500 w/vlans

Answered Question
Jul 10th, 2007
User Badges:

Howdy,

I would like to use LACP wih 2 NIC's on a server connecting to a 6509 blade. Problem seems to be that you can't put a port-channel interface in a vlan. Am I reading the docs correctly? Is there a workaround for this other than haveing a bunch of /30 subnets everywhere?


Thanks,

Mike

Correct Answer by Collin Clark about 9 years 9 months ago

You'll need to configure the port-channel, it will just be layer2.


Heres an example of a switchport-

interface GigabitEthernet9/3

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

speed 1000

duplex full

channel-group 10 mode active


Example of the Port-Channel-

interface Port-channel10

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Tue, 07/10/2007 - 10:28
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi Mike


Could you point to the docs as to where it says that you can't do this. As lomg as all the ports are in the same vlan there is no reason why an etherchannel cannot be an access link rather than a trunk link.


Hope i've not misunderstood


Jon

mbutorac1 Tue, 07/10/2007 - 10:33
User Badges:

Can't remember the exact reference, but anyway, here is what happens if you try it


interface Port-channel2

description Wintel Server

no ip address

shutdown

S3EDC03B#conf t

Enter configuration commands, one per line. End with CNTL/Z.


S3EDC03B(config)#interface port-channel 2

S3EDC03B(config-if)#switchport access vlan 248

Command rejected: Po2 not a switching port.

S3EDC03B(config-if)#

Jon Marshall Tue, 07/10/2007 - 10:41
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mike


I will check this tomorrow but i don't think you tell the port-channel what vlan it is in. You just make sure that the individual ports that make up the port-channel are all in the smae vlan.


HTH


Jon

mbutorac1 Tue, 07/10/2007 - 10:46
User Badges:

Here is what happens when I try to add vlan access to port-channeled ports:


Command rejected (Port-channel2, Gi7/1): Either port is L2 and port-channel is L3, or vice-versa


S3EDC03B(config-if-range)#


This looks like I need more L3 in the mix to me.

Collin Clark Tue, 07/10/2007 - 10:29
User Badges:
  • Purple, 4500 points or more

We trunk the ports instead of trying to use them as access ports. Can you do that?

mbutorac1 Tue, 07/10/2007 - 10:35
User Badges:

Can you expand on your answer? Trunking is normally switch to switch, not host to switch.


Mike

Collin Clark Tue, 07/10/2007 - 10:45
User Badges:
  • Purple, 4500 points or more

You can trunk to a host, you just need a NIC that supports it. We do it with our ESX Servers. By trunking it you will still have VLAN access.

mbutorac1 Tue, 07/10/2007 - 10:58
User Badges:

Sounds like the old joke, you can tune a piano, but you can't tune a fish (couldn't resist!)

So, just 802.1q trunks and no port-channel?

Correct Answer
Collin Clark Tue, 07/10/2007 - 11:04
User Badges:
  • Purple, 4500 points or more

You'll need to configure the port-channel, it will just be layer2.


Heres an example of a switchport-

interface GigabitEthernet9/3

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

speed 1000

duplex full

channel-group 10 mode active


Example of the Port-Channel-

interface Port-channel10

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

Actions

This Discussion