Multiple SSID on 850 series

Unanswered Question
Jul 11th, 2007
User Badges:
  • Bronze, 100 points or more

Hi there


Any one ever got 2 SSID's working on a 850 router?

I've done like this:

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers tkip

!

encryption vlan 2 key 2 size 40bit 0 0123456789 transmit-key

encryption vlan 2 mode wep mandatory

!

ssid Corporate

vlan 1

authentication open

authentication key-management wpa

wpa-psk ascii 7 <removed>

!

ssid guest

vlan 2

authentication open

guest-mode

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

channel 2462

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no snmp trap link-status

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0.2

encapsulation dot1Q 2

ip address 172.16.0.1 255.255.255.0

no snmp trap link-status

!

interface Vlan1

no ip address

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.1.100.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

bridge 1 protocol ieee

bridge 1 route ip


But that makes the guest ssid not working. Corporate SSID works fine.

All I found was this link:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a008045d289.html

But it tells me to bridge the vlan2 interface, however I can't have more then 1 Vlan on the 850 router.

Aaarh! What to do?

Does anyone know what to do?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dsweeny Wed, 07/18/2007 - 08:23
User Badges:

In Cisco IOS Releases 12.4 and later, you can configure SSIDs globally or for a specific radio interface. When you use the dot11 ssid global configuration command to create an SSID, you can use the ssid configuration interface command to assign the SSID to a specific interface.


When an SSID has been created in global configuration mode, the ssid configuration interface command attaches the SSID to the interface but does not enter ssid configuration mode. However, if the SSID has not been created in global configuration mode, the ssid command puts the CLI into SSID configuration mode for the new SSID.


More information available at http://www.cisco.com/en/US/products/ps5853/products_configuration_guide_chapter09186a008067e9f6.html#wp1035858

bcolvin Thu, 07/19/2007 - 12:20
User Badges:
  • Bronze, 100 points or more

One thing try the following for the second vlan

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no snmp trap link-status

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 spanning-disabled

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

add this to the confg below the Interface VLAN 1

!

interface Vlan2

no ip address

bridge-group 2

bridge-group 2 spanning-disabled

!

then finally


below Interface BVI1

!

interface BVI2

ip address 10.1.100.1 255.255.255.0

!





an IP adress should only be configured for Interface BVIx


hope this helps

beabrams Thu, 07/19/2007 - 15:59
User Badges:
  • Cisco Employee,

in early version of code on that router...

when you did the following.

config t

vlan 2 (it would give an error) upgrade the code and then to the bridging you will be fine...


something like 12.4.11T1 etc would do fine.

We have now upgraded to IOS 12.4.11T2, now the vlan 2 can be created.

However, the bridging and bvi2 still doesn't work.

Here is our current config:


ip dhcp pool Corperate

network 10.1.6.0 255.255.255.0

default-router 10.1.6.1

dns-server 192.168.117.1 4.2.2.2

netbios-name-server 192.168.117.1

lease 2

!

ip dhcp pool GUEST

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 4.2.2.2 4.2.2.1

lease 2

!

bridge irb

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers tkip

!

encryption vlan 2 key 2 size 40bit 7 transmit-key

encryption vlan 2 mode wep mandatory

!

ssid GUEST

vlan 2

authentication open

guest-mode

!

ssid Corperate

vlan 1

authentication open

authentication key-management wpa

wpa-psk ascii 7

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

channel 2462

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0.2

encapsulation dot1Q 2

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 spanning-disabled

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Vlan1

no ip address

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.1.6.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface BVI2

ip address 192.168.0.1 255.255.255.0


!

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

bridge 2 route ip


Does anybody have an idea about what is wrong?


tu_amor66 Fri, 08/10/2007 - 07:18
User Badges:

Try assigning the same ip address BVI2 has to Vlan2.

See if that solves the problem.

Actions

This Discussion

 

 

Trending Topics - Security & Network