Ethernet0 WAN config

Unanswered Question
Jul 12th, 2007

interface Ethernet0

ip address xxxxxxx

ip nat outside

backup delay 10 60

backup interface Async5

no ip route-cache

no ip mroute-cache



Hi all. I am a bit confused. in the above configuration, why would I want to disable route cache? I thought that this would speed up switching?

Also, is it standard practice to use half-duplex on a WAN link? I would think auto or full-duplex would provide better results.

Can someone educate me on these topics?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Edison Ortiz Thu, 07/12/2007 - 07:14

You should enable fast-switching on that interface. I've seen IOS releases having fast-switching disabled by default on some interfaces.

Fast-switching is often disabled on an interface when you want to debug packets entering/leaving that interface since during debug and fast-switch on, you are only able to see the first few packets (subsequent packets will be fast-switched).

As far as the half-duplex setting, verify the device connected at the other end supports full-duplexing. If it does, configure both for full-duplex during off-hours - there will be a small interruption during this change.

Richard Burts Thu, 07/12/2007 - 07:19

I would be curious to know what kind of platform this is. I note that the interface is Ethernet0 (not fastethernet) which implies that it is 10Mb only. Many of the Ethernet interfaces only support half duplex operation.

I do agree that the no ip route-cache is a bit unexpected.



Edison Ortiz Thu, 07/12/2007 - 07:22


I agree about the limitation on some Ethernet interfaces regarding duplexing. However, when I seen that case, the setting (half-duplex) is not even listed in the config as there isn't any other option. When the command is listed, more often than not, the full-duplex option is available.

slayerhawk Thu, 07/12/2007 - 07:25

This is a branch location that creates a VPN tunnel to our PIX 515. This makes sense, since the PIX has 10MB limits. Or am I missing the point?

Edison Ortiz Thu, 07/12/2007 - 07:30

Verify the PIX LAN interface supports full-duplexing. If it does, change the duplexing mode on both devices at the same time. You can't have one device configured as full-duplex and the other as half-duplex. The link will go down and remain down until they match.

slayerhawk Thu, 07/12/2007 - 07:35

They both match. I'm experiencing poor application performance at several branch locations that use Outlook to connect to our Exchange server at HQ through the PIX. It's hard to find out what is causing slowdowns for them.

Edison Ortiz Thu, 07/12/2007 - 07:38

half-duplex will certainly affect network performance. As I said before, verify that you can change the duplex setting on the PIX and change both to full-duplex.

Richard Burts Thu, 07/12/2007 - 07:36


What is the branch router physically connected to? That is what is important in terms of the duplex setting.

Edison makes a good point that if the interface were only capable of half duplex that the config option would probably not show up. And it occurs to me that if it is showing up in the config listing that it is probably not the default setting for the interface.

So check on what the branch router is connected to and see if that device supports full duplex (and if it supports negotiation of duplex).



chrihussey Thu, 07/12/2007 - 07:19

1- In some cases "no ip route-cache" or fast switching needs to be turned off for NAT to work properly. This may be the case here.

2- Full duplex is obviously better than half, but you need to see if this setting is feasible on both the router and the device it is connected with.

Regards -


This Discussion