dhcp issue for phone

Unanswered Question
Jul 12th, 2007

Im having an issue getting dhcp to work with my ip phones. can someone help and see what I did wrong? Thanks.

ip dhcp excluded-address 10.25.102.1 10.25.102.10

!

ip dhcp pool VOICE

network 10.25.102.0 255.255.255.0

dns-server 10.25.6.10

default-router 10.25.102.1

option 150 ip 10.25.100.10

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/1

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/2

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/3

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/4

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/5

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/6

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/7

switchport voice vlan 102

spanning-tree portfast

!

interface FastEthernet0/1/8

switchport voice vlan 102

spanning-tree portfast

!

interface Vlan1

ip address 10.25.7.1 255.255.255.0

!

interface Vlan2

no ip address

shutdown

!

interface Vlan102

ip address 10.25.102.1 255.255.255.0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
mchandak Thu, 07/12/2007 - 09:36

I've seen one issue in the past where phones were unable to pick IP Address from a IOS DHCP Server. The fix for this was to run the command "clear ip dhcp conflict *". If this does not resolve the issue, then let me know the Firmware running on the phones

jjoseph01 Thu, 07/12/2007 - 11:03

tried different phone, still the same. tried your command, still the same.

mchandak Thu, 07/12/2007 - 11:05

When you hit Settings and then go Under Network Settings, does the DHCP Server show as 0.0.0.0 or there is nothing listed there ??

Also, does the phone get stuck at Configuring VLAN or Configuring IP

AJAZ NAWAZ Thu, 07/12/2007 - 11:16

Attach a pc or laptop to VLAN 102. Configure the port as a normal access port i.e. host port. Try to get DHCP address. If you succeed then your config is fine, and we need to then look into the phones and switchport configuration.

jjoseph01 Thu, 07/12/2007 - 11:37

hooked laptop to port, configured for swithcport access vlan 102. release and renew of IP, wont get anything.

oksiazek Thu, 07/12/2007 - 12:56

Hi ,

Your problem is probably due to the fact that the interface vlan 102 is not UP !!!

Try the show interface and you will see it probably . So the Dhcp messages cannot occure .

Do this to correct the situation .

Go into config mode

type :

interface range fa0/1/0 - 7

switchport mode trunk

And normally , your interface vlan 102 will go UP . So now when you will connect an ip Phone , it will take an address in the Voice DHCP ( Voice vlan ).

Let me know if it corrects your problem .

Thanks

Olivier

johnhsnow Thu, 07/12/2007 - 13:01

Another thing you investigate is if DHCP needs to be enabled. Im not sure what IOS you are running ( could you post a sh ver? ) but try this command:

service dhcp

to enable dhcp services.

Hope that helps.

johnhsnow Thu, 07/12/2007 - 13:14

Another few points to consider: if my previous suggestion fails.

In your configuration try:

1. Native vlan - Determine if interface vlan8 is up/up. If not, try shutting down interface vlan1 and removing ip address> check interface vlan8 again on up/up status.

2. If your only running voice services you wont need a trunk configuration. If you have a pc connected through your phone you need to unplug it and plug phone direct in or configure your switchports as trunks for proper tagging.

3. Last question.. what is your default router pointing to?

default-router 10.25.102.1

jjoseph01 Thu, 07/12/2007 - 13:36

ok, put all ports as trunk ports. It worked ONCE. I got an ip address, it came up with some mismatch error, and now it wont get an ip address anymore. I tried another phone on another port, didnt get one. I currently have them set to trunk ports, because they do run data across it too. My router as a default route back to the main site. Everything is to go over to the main site first. As far as shutting down the vlan1, we are in a live environment, they might not like their data going down right now.

johnhsnow Thu, 07/12/2007 - 15:37

Do you know what the error was exactly? Is your switch configured in a vtp domain? Check to make sure your vlans are still configured the way you expect them to be.

Sorry, I was assuming vlan1 was not Native vlan which im used to in the environment I am in.

jjoseph01 Thu, 07/12/2007 - 20:03

wow, still no progress on this. Here is what I have found: From the router that is handing out dhcp, I can not ping anything on the phone vlan, including my laptop which I put a static ip address (in the voice vlan). If I look in the arp table, it will show the mac address of the static ip addressed assigned device, but can not ping it. If I do a tracert from the callmanager server, same thing, I get a response from the router, but not the last ip I should get (the device). Funny thing though, on the phone, it will show the voice vlan ID, but nothing else (unless I put a static ip on it). I have tried two different phone models, upgrade of IOS, putting voice vlan in the vlan database, setting ports to trunks, back to access ports, all advice above, etc. No clue at this point.

johnhsnow Thu, 07/12/2007 - 20:27

Try this:

1. show ip dhcp binding

2. clear ip dhcp binding

3. show ip dhcp conflict

4. clear ip dhcp conflict

5. term mon

6. debug ip dhcp server packet

7. debug ip dhcp server events

Regards,

John

mchandak Fri, 07/13/2007 - 00:33

From the config you have pasted it always looked like the DHCP Server and the phones are on hte same device, as in the switch is being used for DHCP. If the Router which handles DHCP does not host the phones, can you paste the config from the router for the port which is used to connect to the switch along with the config of the port on the switch. Looks like we have some issue with connectivity here as when you assign it an Static IP as well, nothing works.

jjoseph01 Fri, 07/13/2007 - 04:24

Yeah, have created the vlan 102. As far as the switch goes, it is part of the router. It is a hwicd-9esw module that fits in the 2811.

mchandak Fri, 07/13/2007 - 05:05

if you have an HWIC, I dont think VLAN interface would work. An HWIC only works as an Layer 2 Device, therefore the VLAN interface would not really work. Can you check the output of the following 2 commands:

1. show ip interface brief. Does this command show vlan 102 with the Status of UP/UP ??

2. show ip route on the router. It should show an route to this IP Subnet as directly connected.

If the above 2 do not work, then I guess you will have to assign the IP Address to a Physical Interface and then try.

jjoseph01 Fri, 07/13/2007 - 06:11

tried both. up and up for vlan and routes show directly connected for that ip scheme. Cisco has forwarded me to 4 different departments at this point. This must really be a complex issue. I appreciate everyones persistance in helping and ideas. Keep em coming.

mchandak Fri, 07/13/2007 - 06:21

can you paste the output of "show ip route" and show vlan brief from the router

jjoseph01 Fri, 07/13/2007 - 06:23

All, I did this: I made a dhcp scope for the data vlan (vlan1), and it picks up an ip from that vlan and the phone actually works fine. But, its not on the right vlan at this point and I cant get it to get dhcp from the voice vlan. Any ideas?

jjoseph01 Fri, 07/13/2007 - 06:54

All, problem is solved. Here is what I had to do to get the phone to get an ip from the voice vlan pool:

interface FastEthernet0/1/3

switchport mode trunk

switchport voice vlan 102

spanning-tree portfast

Thanks to everyone for the ideas and persistence. I really appreciate the help on this.

Actions

This Discussion