Hybrid to Native IOS conversion on SUP2/MSFC2

Unanswered Question
Jul 12th, 2007

I went to the section that says:

"Conversion on Supervisor Engine with MSFC2" at the link

http://www.cisco.com/en/US/partner/products/hw/switches/ps708/products_tech_note09186a008015bfa6.shtml#conv_msfc_2

This link is for Hybrid to Native OS conversion.

Everything was fine until I got to step 16.

Step 16 says:

You are now in RP ROMmon because the configuration register on the MSFC2 has been set to 0x0. RP ROMmon cannot read the SP bootflash or the PC card with the dir command at this stage. However, you can issue the boot sup-bootflash: command or the boot sup-slot0: filename command in order to boot from these devices.

Issue the boot command for the device where the Cisco IOS Software image (c6sup22*) is stored.

rommon 1 > boot sup-slot0:c6sup22-js-mz.121-19.E1a

Found that RP Rommon cannot see sup-slot0:

Tried dir sup-slot0: at RP Rommon at this step and that could not see the PCMCIA card in slot 0.

Any suggestions - or do I have some sort of H/W problem in SUP2 or MSFC2, which I suspect because if I leave in the above condition and stay in RP Rommon - after a few minutes the SP crashes with S/W forced crash.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Thu, 07/12/2007 - 18:31

Sure it is sup-slot0: and not sup-disk0: ? Check to see if its sup-disk0:

astanislaus Thu, 07/12/2007 - 18:36

Can see why

dir sup-slot0:

did not work, because step 16 says dir won't work. But why

rommon 1 > boot sup-slot0:c6sup22-js-mz.121-19.E1a

at step 16 failed to boot RP.

But at step 15:

rommon 2 > boot slot0:c6sup22-js-mz.121-19.E1a

worked fine.

astanislaus Tue, 10/02/2007 - 15:45

Found the answer. Replace the word slot0 by disk0. I think if the size of this card is above a certain value we say disk0 and below that size we say slot0. Anyway if slot0 doesn't work then try disk0.

Actions

This Discussion