Layer 2 switching problem

Unanswered Question
Jul 13th, 2007
User Badges:

Hi,


I got a problem with communication between two servers in the same Vlan, on the same switch(Cat6509-Sup720) and on the same module (WS-X6748-GE-TX). Servers has only layer 2 interfaces without IP assigned to it and those interfaces are very quiet, not sending any traffic. Problem starts when one server want to open communication using mac address of the other server. Switch doesn't know where is destination MAC, so it should flood this packet on all ports in this Vlan. But from tcpdump on both servers I see that it is not doing that!

Server A send packet to B (communication fails)

Server B send packet to A (also fails)

Server B send packet to A (this goes fine).


I have been searching for problem for week now, and could now find anything.

Could You tell me how to trace if flooding is not happening?

Thank You for any suggestions.


Regards:

Michal


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
berkous1 Fri, 07/13/2007 - 02:54
User Badges:

As far as i know, The communication goes this way : The server A wants to talk to server B so it's got the ip address and not the mac address. This request goes to the switch/router which got the correspondance mac/IP and if the S/R hasn't got the dest mac @ in its table it floods by a broadcast to all the ports except the one it has received the request from.


The request could be a layer 2 broadcast too and in this case, the destination mac address is not the server's one.


Do u use a specific application that doesn't need IP?

Is your vlan a layer 2 or a layer 3 vlan (have u configured a SVI)?

Tell us a little bit of the goal of this communication and someone will find the answer ...


Regards,

Abdelkrm


michal.grzelak Fri, 07/13/2007 - 03:48
User Badges:

Hi berkous1,


Thx for answering. Each server has interface without IP assigned to it and moreover it is not sending any traffic unless want to unicast communicate with other server (using linkloop mac_addr). I asked to do tcpdump on that interfaces during the transmission and I see that switch is not flooding the packet using broadcast.

Answers to Your questions:

-Yes, this server interface needs to run using layer2 NIC,

-there is layer3 interface of this Vlan, but located on core switch. Server is connected to access layer switch.

-I only know that the porposue of this is a failover, but now they are testing layer2 communication between servers.


I think that problem is that switch doesn't flood network with packet where it doesn't know destination MAC address.


Regards:

Michal

Actions

This Discussion