×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.
paolo bevilacqua Sat, 07/14/2007 - 01:19
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Is the caller-id service present and working on the line ?

Is the voice-port configured for caller-id and correct cptone ?

peternnaji Mon, 07/16/2007 - 00:42
User Badges:

Hi bevilacqua

Yes the cptone is correct, but not so sure of the voice-port config for caller-id. an you help out?

paolo bevilacqua Mon, 07/16/2007 - 00:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

First of all you have to test the service by connecting a regular phone with caller id to the line, and verify that you can receive caller id.


Then for configuration, under voice-port just configure "caller-id enable".


If caller id doesn't work, please send configuration and output of "term mon" and "debug vpm signal" when receiving a call.


Hope this helps, please rate post if it does!

paolo bevilacqua Tue, 07/17/2007 - 02:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


You have no analog voice port so there is no need to configure caller-id. Please look at the output of "term mon" and "debug isdn q931" to observe which calling number is being sent from telco.


Note: these commands that you have configured:

voice call send-alert

voice call convert-discpi-to-prog always

voice rtp send-recv

voice disc-pi-incoming-on


Unless you have a reason to have them, are unnecessary and can be cause of trouble.

Actions

This Discussion