Configuring PVST on 3500XL

Answered Question
Jul 13th, 2007

I have a WS-C3524-PWR-XL I'd like to bring in to temporary service, and need to migrate it from STP to PVST. Does anybody know the command(s) to do this? Usually it's "spanning-tree mode pvst", but even with the latest IOS I don't have that option:

Switch(config)#spanning-tree ?

forward-time Set a Spanning Tree FORWARD Interval

hello-time Set a Spanning Tree HELLO Interval

max-age Set a Spanning Tree MAX AGE Interval

portfast Allow a change from blocking to forwarding

priority Set a Spanning Tree Priority

protocol Spanning tree protocol type

uplinkfast Enable UplinkFast Feature

vlan VLAN Switch Spanning Trees


The IOS version is 12.0(5)WC17

I have this problem too.
0 votes
Correct Answer by Francois Tallet about 9 years 6 months ago

On those switches, there is a difference between the number of vlans supported and the number of STP instances supported.

Doing a google search, I found this page, that states that the 3500XL supports 64 stp instances and 250 vlans.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Francois Tallet Fri, 07/13/2007 - 08:50

Hi John,

I don't know the exact release or the exact hardware you are mentioning, but this switch is already running PVST. In fact, PVST was the only option on Cisco switches before we introduced MST and then Rapid-PVST. So the good news is that you don't need to do any migration;-)



Amit Singh Fri, 07/13/2007 - 08:56

All cisco switches actually run PVST+,including the 3500XL. You can see this information in the link below. If you do a "show spanning tree", it will show that the mode is PVST. So you don't really configure STP with PVST, it is there by default.

HTH,Please rate if it does.

-amit singh

johnnylingo Fri, 07/13/2007 - 10:35

OK, that is what's confusing me because I never see any mention of PVST with the "show spanning-tree summary" or "show spanning-tree" commands, but if I plug in a packet sniffer to a trunked port I see a BPDU for each VLAN every 2 seconds so that's enough to convince me ;)

Anyway, the reason I was asking about this is I noticed as soon as I configured a trunk port, the switch disables STP for our last 41 VLANS (we have 109 total). This would make perfect sense on a 2900XL since there's a limit of 68, but the 3500XL has a limit of 254 so I don't see why it's doing this.

no spanning-tree vlan 69

no spanning-tree vlan 70

no spanning-tree vlan 71


no spanning-tree vlan 108

no spanning-tree vlan 109

Ideas? The switch is running VTPv2 and pruning is enabled.

3500XL#show vtp status

VTP Version : 2

Configuration Revision : 484

Maximum VLANs supported locally : 254

Number of existing VLANs : 109

VTP Operating Mode : Client

VTP Domain Name : XXXXXX

VTP Pruning Mode : Enabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

MD5 digest : 0x58 0x2B 0x4F 0x85 0xA6 0x98 0x07 0x59

johnnylingo Fri, 07/13/2007 - 10:50

Ahhh...ok then. These switches will only need be a part of STP for our wireless VLANs, so my solution will be use "switchport trunk allowed vlan" to limit STP to those ones.


This Discussion