HSRP malfunction on subinterfaces

Unanswered Question

I configured nine HSRP Groups with two Routers and two Catalyst 2960 Switches.

Active Router: Cisco 7507, Standby Router: 7206 Router

One Physical Interface FastEthernet0/0 was divided into nine subinterfaces.

Catalyst 2960 Switches was configued 802.1q trunk between two Routers and themselves.

Aside from 7th subinterface, the others of both routers was configured nearly similarly.

7th subinterface config of the C7507 Router: Active Router

interface FastEthernet0/0.107

bandwidth 5000

encapsulation dot1Q 107

ip vrf forwarding XXX

ip address 10.0.49.42 255.255.255.248

standby 107 ip 10.0.49.41

standby 107 priority 150

standby 107 preempt

7th subinterface config of the C7206 Router: Standby Router

interface FastEthernet4/0.107

bandwidth 5000

encapsulation dot1Q 107

ip address 10.0.49.43 255.255.255.248

standby 107 ip 10.0.49.41

standby 107 preempt

If you need to understand the detail diagram, please refer to the attached file.

Today morning, when I applied "shutdown" command to one of the subinterfaces,

A problem suddenly occured about HSRP function.

In other words, HSRP state was changed from Active-Standby state to Active-Active state.

At that time, I issued "ip vrf forwarding XXX" command to 7th subinterface on FastEthernet0/0 of the C7206 Router, and then

HSRP function back to the normal state (Active-Standby)


What is the root cause in this case?

Is there a problem concerning HSRP configuration between MPLS VPN and Legacy Network?

Feel free to tell me anything.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
swaroop.potdar Fri, 07/13/2007 - 11:14

Hi, when you configure vrf forwarding on one subif and none on the other corresponding subif. Then this is bound to happen.


But this would not be a correct configuration, as the corresponding interfaces of a HSRP group either hsould be in global or VRF, but not simultaneously both.


As the one with vrf forwarding is acting in a VRF aware HSRP mode and it will refer to the VRF attached ARP table for any resoulutions and one with none is acting in global hsrp mode which will refer to the global arp table.


Hence each router thinks they are active in their own modes, and they are also able to send keepalives to each other on the directly connected link.


Here is a link for this feature.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a00806993c5.html


HTH-Cheers,

Swaroop

Tankyou for your kindly response to my previous a message.

When I was faced with HSRP Issue,

I applied "shutdown" command to all of subinterfaces of the C7507 Router aside from management interface F0/0.10.

Please refer to attached "config.txt" file.

Only One subinterface, management F0/0.10, was up in C7507 Router and

all subinterfaces of the other side Router remained up.

But HSRP on each side of Routers continued to be Active-Active state concerning management interface F0/0.10.

At that time, I applied "ip vrf forwarding XXX" command to 7th subinterface of the C7206 Router and this issue finally was resolved.

I have no idea on this case.

First question: Why were affected all of subinterfaces dut to the change of state on one subinterface.

Second question: Although management interface was configured compling with common hsrp config rule,

why did both routers indicated that own interface about management hsrp group had active roll.


A matter that I can not understandable more than above two questions is following,

In 7th subinterface of the C7206 Router, after "ip vrf forwarding XXX" command was typed , how did this problem finish?

please tell me something ASAP.



Attachment: 
swaroop.potdar Sun, 07/15/2007 - 21:41

It was unthoughful of me to reply at the first though that ran across my mind.


Please ignore my previous post.


Actually even if you use one side with vrf and other without the vrf there wont be a Active-Active state.


There can be a active active state only if both the routers miss each other hellos for the configured hold time. And this can happen only if there was a instability between your switches as all the other interfaces were up when you shut one subinterface.


There is a bug as well which might create this but this is quite old, and might not be affecting your setup, but still take a look at this link.


http://www.cisco.com/warp/public/619/8.shtml


Appreciate your time,


HTH-Cheers,

Swaroop

Actions

This Discussion