Aironet 1240AG - cant use the web interface

Answered Question
Jul 14th, 2007
User Badges:

I am trying to configure a new Aironet 1240AG. After it picked an ip address from the DHCP in my lan, I still can't log in using the web interface. I am using an Internet Explorer 6.0 on Win 2000. It keeps telling me cannot find server. please i need assistance

Correct Answer by Rob Huffman about 9 years 10 months ago

Hi Obinna,


Maybe try this (highly recommended version)


Solar Winds tftp

http://www.solarwinds.net/Tools/Free_tools/TFTP_Server/


The problem could be that the Laptop (used for TFTP) Operating System is hiding the known file type. From Internet Explorer, go into Tools > Folder Options > View, scroll down until you find the parameter Hide extensions for known file types, and uncheck the box. This should eliminate the issue.


Hope this helps!

Rob


Correct Answer by Rob Huffman about 9 years 10 months ago

Hi Obinna,


First off you are most welcome :) This method definitely works without the need for a WLC, be patient. Check the static IP address you set on your TFTP (**10.0.0.2 to 10.0.0.30 range)


Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point


Sounds like a TFTP problem (no firewall on your PC?)


Have a look at the details in the following threads that all have to do with TFTP. There are some great hints for troubleshooting TFTP problems from some of my favourite NetPros like ScottMac,Stephen from Cisco and Jack Young. The likely culprit may be that you need to uncheck "hide extensions for known file types" on your TFTP server;


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=WLAN%20Radio%20Standards&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddc042b/8#selected_message


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=General&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddc03c4/2#selected_message


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=General&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddbf271


Hope this helps! Good Luck!

Rob


Please remember to rate helpful posts.....

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
rnigam Sat, 07/14/2007 - 03:27
User Badges:

Are you able to telnet/colsole into it?


If yes, the command to set up a new password would be

apname(config)# username Admin priv 15 password yourpassword.

richnam Sun, 07/15/2007 - 04:28
User Badges:

thanks rob for your time and input.

However, i couldn't open the link you sent.

The AP1242AG runs on IOS 12.3.11 JX.

I can't log into it even when i type the dhcp assigned ip address of the AP on a web brower. There is no WLAN controller on the lan but this shouldn't prevent me from logging in with HTTP. Please help me out.

Thanks

Rob Huffman Sun, 07/15/2007 - 04:46
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Obinna,


Sorry about the link :( The problem here is the fact that 12.3.(11)JX is a Lightweight image. Have a look;


Warning: All Cisco Aironet Access Points receiving Cisco IOS Software Release 12.3(11)JX will only function in conjunction with a Cisco Wireless LAN Controller. They will no longer be able to function as Cisco Aironet Autonomous Access Points.


This product bulletin describes the content and delivery information for Cisco IOS Software Release 12.3(11)JX. This is a Cisco Lightweight Access Point Protocol (LWAPP) upgrade and recovery support software image supporting Cisco Aironet 1100, Aironet 1130, Aironet 1200, Aironet 1230 AG, Aironet 1240 AG, and Aironet 1300 Series Access Points.


http://www.cisco.com/en/US/products/ps5861/prod_bulletin0900aecd804b1a72.html


You can use this method to convert the AP back to Autonomous Mode (and access via Web);


Reverting the Access Point Back to Autonomous Mode


http://www.cisco.com/en/US/products/hw/wireless/ps430/prod_technical_reference09186a00804fc3dc.html#wp161272


You can convert an access point from lightweight mode back to autonomous mode by loading a Cisco IOS Release that supports autonomous mode (Cisco IOS release 12.3(7)JA or earlier). If the access point is associated to a controller, you can use the controller to load the Cisco IOS release. If the access point is not associated to a controller, you can load the Cisco IOS release using TFTP.


Using a TFTP Server to Return to a Previous Release


Follow these steps to revert from LWAPP mode to autonomous mode by loading a Cisco IOS release using a TFTP server:



--------------------------------------------------------------------------------


Step 1 The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30.


Step 2 Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.122-15.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.


Step 3 Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point, c1130-k9w7-tar.default for an 1130 series access point, and c1240-k9w7-tar.default for a 1240 series access point.


Step 4 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.


Step 5 Disconnect power from the access point.


Step 6 Press and hold MODE while you reconnect power to the access point.


Step 7 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds) and then release.


Step 8 Wait until the access point reboots, as indicated by all LEDs turning green followed by the Status LED blinking green.


Step 9 After the access point reboots, reconfigure it using the GUI or the CLI.


From this doc;


http://www.cisco.com/en/US/products/hw/wireless/ps430/prod_technical_reference09186a00804fc3dc.html#wp161272


Hope this helps!

Rob



richnam Sun, 07/15/2007 - 04:57
User Badges:

Thanks a 1000 times rob for your time and info.

However, i have gone through the 9 steps to revert back to autonomous mode IOS 12.3.7-JA. But while booting, after the status led turns red, i get the following messages from the console

1. The AP will search for the default IOS file image at file\\255.255.255.255\c1130-k9w7-tar.default

2. Unable to open file\\255.255.255.255\c1130-k9w7-tar.default..... no such file

Does this suggest that i'll have to use a controller to load this image? cos thats the only other way possible.

Regards,


Correct Answer
Rob Huffman Sun, 07/15/2007 - 06:09
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Obinna,


First off you are most welcome :) This method definitely works without the need for a WLC, be patient. Check the static IP address you set on your TFTP (**10.0.0.2 to 10.0.0.30 range)


Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point


Sounds like a TFTP problem (no firewall on your PC?)


Have a look at the details in the following threads that all have to do with TFTP. There are some great hints for troubleshooting TFTP problems from some of my favourite NetPros like ScottMac,Stephen from Cisco and Jack Young. The likely culprit may be that you need to uncheck "hide extensions for known file types" on your TFTP server;


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=WLAN%20Radio%20Standards&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddc042b/8#selected_message


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=General&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddc03c4/2#selected_message


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=General&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddbf271


Hope this helps! Good Luck!

Rob


Please remember to rate helpful posts.....

richnam Sun, 07/15/2007 - 08:39
User Badges:

Thanks alot.

Sure i'll rate this. Its been of good help.

I'll check the links you provided.

Please can you suggest any tftp software?

I was using tftpd32, recommended by cisco. And i can't find the "hide extensions for known file types" check button. Maybe you can help me with the one you've used before.

Regards,


Correct Answer
Rob Huffman Sun, 07/15/2007 - 10:23
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Obinna,


Maybe try this (highly recommended version)


Solar Winds tftp

http://www.solarwinds.net/Tools/Free_tools/TFTP_Server/


The problem could be that the Laptop (used for TFTP) Operating System is hiding the known file type. From Internet Explorer, go into Tools > Folder Options > View, scroll down until you find the parameter Hide extensions for known file types, and uncheck the box. This should eliminate the issue.


Hope this helps!

Rob


Rob Huffman Sun, 07/15/2007 - 13:57
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Obinna,


Great work! You are most welcome :)


Take care,

Rob

Actions

This Discussion