Cisco 2960 Multicast Flooding

Unanswered Question
Jul 14th, 2007

I configured a VLAN with 2 ports on a Cisco 2960 48TT switch and connected a host to one port which is sending a number of unicast, multicast and broadcast UDP messages.

Next I connected an analyzer to the other port and observed the unicast and broadcast messages, but not the multicast messages.

Since the end host is not IGMP capable, I disabled IGMP snooping.

The VLAN was mirrored (span session) to another port on the switch and connected to an analyzer and the multicast messages were observed, so I am assured that the multicast messages are arriving at the VLAN but are not being flooded.

I ensured that unicast and multicast flooding was enabled and I disabled security for the ports on the VLAN.

From all the documentation that I have read on this switch, the multicast messages should flood if IGMP snooping is disabled.

Do I need to perform any other steps?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
keegan.holley Sat, 07/14/2007 - 15:43

What kind of multicast traffic is it? If it is link local traffic (IE 224.0.0.x) IGMP is not used. This is due to the fact that the sender must be in the same subnet. Have you tried sniffing with a different host? IIRC, with IGMP off the switch no longer knows the difference between broadcast and multicast traffic. It should just replicate any frame with the 9th bit in the dest mac address set to one to every port except for the one on which it was received. Are you getting any multicast traffic in your traces? Spanning tree, vrrp/hsrp or ospf from the local router etc.


This Discussion