After upgrade to Campus 4.0.9. - all links "not in network"

Unanswered Question
Jul 15th, 2007

After the upgrade to Campus Manager 4.0.9, all links are now shown as "not in netwerk" (red dotted line).

Any help would be appreciated.

Tx.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
joris.everaert@... Sun, 07/15/2007 - 05:25

I think I already did this : I used the "Start Data Collection" link, selected "All Devices" and that job completed.

The devices are all in green, it's just the links that are all in alert.

Joe Clarke Sun, 07/15/2007 - 14:56

If the links still show red, enable core, corex, and topo debugging under Campus Manager > Admin > Campus Data Collection > Debugging Options, then run a new Campus Data Collection, and reload the topology map. The ani.log should have some indication of why the links are showing not in network.

joris.everaert@... Sun, 07/15/2007 - 21:22

Tx for the help.

Underneath some of the errors we see repeating :

2007/07/16 07:04:45 EvalTask-background-39 ani ERROR StpSMFGetStpInstance: unable to get stp device information

2007/07/16 07:04:45 EvalTask-background-27 ani ERROR StpSMFGetStpInstance: unable to get stp device information

2007/07/16 07:04:45 EvalTask-background-22 ani ERROR StpSMFGetSpanTreeDeviceInfo: Unable to fetch spanning tree type info from device "blanked out on purpose" com.cisco.nm.lib.snmp.lib.SnmpValueException: Illegal Access. NoSuchInstance being accessed as Integer.

2007/07/16 07:04:45 EvalTask-background-34 ani WARNING VlanStpInstance: unable to find vlan instance for instance id1003

2007/07/16 07:05:57 Discovery ani TopoSMFGenerateElmiTopology: Skipping device "blanked out on purpose" because ELMI neighbors are not discovered

2007/07/16 07:05:57 Discovery ani TopoSMFGenerateCdpTopology: Skipping device "blanked out on purpose" because CDP cache is not discovered

Then all links are shown as "not in network"

Joe Clarke Sun, 07/15/2007 - 21:57

Nothing here speaks to an exact cause. If you cannot share the entire log on the forum, open a TAC service request, and attach the log.

u.seidel Sun, 07/15/2007 - 23:39

I have the same problem. Likewise after loose contact to a device( device red )and after the devive is back it will stay red. Perform data collection doesn?t help. Is it possible to deinstall the patch?

Joe Clarke Mon, 07/16/2007 - 05:36

No, the 4.0.9 update cannot be uninstalled. The debugging I mentioned previously might help determine what the cause of this problem is.

dainat-bis Wed, 07/18/2007 - 06:42

I have the same problem also UT doesn't scan the network devices correctly anymore. Seems that the update to CM4.0.9 wasn't a good idea.

UCBNOCWAN Thu, 07/19/2007 - 19:54

I have the same problem. And in addition to the above problems any new device added after upgrading to 4.0.9 is not being discovered in topology database , and is not being displayed in the Network Topology.

UCBNOCWAN Thu, 07/19/2007 - 21:25

I guess there was a problem with the ANI database. Once I did a cleanup of the database by re-initializing the database (complete). The Discovery , Data collection ran completely and now every thing seems to work.

Note: Re-initializing the database will erase the database completely.

joris.everaert@... Sun, 07/22/2007 - 02:48

This solved my problem. Tx.

For those of you who need to look like me for the instruction : run perl reinitdb.pl in the campus/bin folder from the command line.

chharris41 Mon, 08/06/2007 - 14:32

Hi,

I am having this same issue after upgrading to Campus 4.0.9 - all limks show as red. I read the solution and have question regarding the caveat about the re-init of the ANI database saying it "erases" the database.... what is the effect of that? Is it just a matter of doing rediscovery/data collection or are there further issues associated with the re-init? In other words, what do I have to be cognizant of if I do this? I have heard of no other solution to this issue so any advice would be greatly appreciated.

Joe Clarke Mon, 08/06/2007 - 14:41

When you reinitialize you Campus Manager database, you lose all topology and User Tracking data. This means that you will need to do a new Data Collection followed by a new User Tracking Acquisition once dmgtd restarts.

chharris41 Mon, 08/06/2007 - 20:00

Ok - I tried this procedure and it worked like a charm! I did campus data collection after the re-init of ANI database and my topology maps are back to way they were before upgrade to CM 4.0.9

Appreciate the solution given from list members - I would never have come up with this on my own and it saved me alot of grief....

THANKS ALL!!

Joe Clarke Wed, 08/15/2007 - 09:07

I finally received a debug log for this issue, and was able to determine the root cause. I filed CSCsk08540 to track the issue. While a reinit of the ANI database is a workaround, I also have a patch that is available by calling the TAC which will prevent this problem from occurring in the future.

ians_2503 Mon, 08/20/2007 - 01:25

Is the patch that is available to be applied before the upgrade or will it correct this after the upgrade has been applied?

We have upgraded to 4.0.9 and all of our links are showing as dotted red lines. re-initializing the ANI database is not an attractive option to us as we will have to redo all of our topology maps for our entire network.

Joe Clarke Mon, 08/20/2007 - 08:03

The patch is for CM 4.0.9 after the update has been applied. It will immediately solve the problem upon running a subsequent Data Collection. Reinitializing the ANI database is not needed with my patch.

Jeroen Tebbens Thu, 08/30/2007 - 05:09

Where can we get this patch? We have a customer that has the same problem (CM 4.0.9 upgrade and Topology is red dotted lines).

Joe Clarke Thu, 08/30/2007 - 08:16

You have to contact the TAC and reference the bug I mentioned in this thread.

Actions

This Discussion