MOH audio format

Answered Question
Jul 16th, 2007

Hello all,

I had uploaded a new MOH, It seems that the uploaded message status is fine( status ok in all output file list).

But someone put me in hold, I just hear "bip bip bip".

Maybe is there any format problem ?

What is exactly the require file format?

Thanks & Regards,

Etienne

I have this problem too.
0 votes
Correct Answer by j.huizinga about 9 years 4 months ago

Hi,

Try to do a reset of the MOH server (I assume you are using CM not CCME)

Jan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
rob.huffman Mon, 07/16/2007 - 07:12

Hi Etienne,

There are a number of reasons why callers hear Beeps instead of MOH (especially for Internal calls). Have a look;

Restrictions for Music on Hold

IP phones do not support multicast at 224.x.x.x addresses.

Cisco Unified CME 3.3 and earlier versions do not support MOH for local Cisco Unified CME phones that are on hold with other Cisco Unified CME phones; these parties hear a periodic repeating tone instead.

Cisco Unified CME 4.0 and later versions support MOH for internal calls only if the multicast moh command is used to enable the flow of packets to the subnet on which the phones are located.

Internal extensions that are connected through an analog voice gateway (Cisco VG 224) or through a WAN (remote extensions) do not hear MOH on internal calls.

Multicast MOH is not supported on a phone if the phone is configured with the mtp command or the paging-dn command with the unicast keyword.

From this excellent CME doc;

Configuring Music on Hold

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00807dab90.html#wp1010333

nonosensei Mon, 07/16/2007 - 07:20

Hi,

Thanks for your reply.

Nevertherless, I think MOH is already well configured because it usually works.

I just tried to add a new file in the MOH audio source and changed it in a profile.

I changed again to the first MOH audio file and it does work normally.

My file is actually in the right format : 8 bits, 8 khz, mono CCITT u-law.

I really don't know where the problem is comes from.

Regards

Correct Answer
j.huizinga Tue, 07/17/2007 - 01:52

Hi,

Try to do a reset of the MOH server (I assume you are using CM not CCME)

Jan

ggivenemergeits Thu, 05/27/2010 - 10:44

I have taken the time to document this and feel it woul be beneficial to others

please rate if you find this helpful

Download Audacity ( google it)

open audacity

Change Project to 8000hz (lower left hand corner)

Go to edit and then preferences

Change Uncompressed export format to “ AU (Sun/Next 8:bit ULAW)”

Load audio file

Select a space where someone is not speaking

Go to effect and noise removal

Click get noise profile

Close effect

Select all

Choose effect and noise removal

Click remove noise

Select all

Choose effect and then normalize

Click ok

Select all

Choose effect and then compressor

Change threshold to -42db

Change ration to 10:1

Uncheck normalize

Click ok

Click file

Choose export as au.

Save as “ filename.au”

Upload file to router via tftp

specify the file in CME GUI

Actions

This Discussion