AD to DCD

Unanswered Question
Jul 16th, 2007
User Badges:

Hi there,


We recently changed the configuration of our CCM 4.2.3 from AD to DCD following the procedure mentioned in the document <http://www.cisco.com/en/US/customer/products/sw/voicesw/ps556/products_tech_note09186a00800ab82d.shtml> but even though we have configured all the parameters as explained on that document, it seems that AD is the default directory yet, also whenver we try to access the add new user page, we get an error saying "Error

The following error occurred while trying to load the requested page.


The phone administrator is currently not allowed to add or delete users. Click here to reload"


So far we have not been able to accomplish what we need, any help is appreciated.


TYIA

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mchandak Mon, 07/16/2007 - 07:44
User Badges:
  • Gold, 750 points or more

Personally, I think this document needs to be updated and the would not work for CM 4.x. The most simple option to get around this is to re-run the AD Plugin. It will ask you if you want to Upgrade/Remove the plugin. Select remove and let the exe change the settings as this information is no longer stored only in Registry. The same info is stored in DirectoryConfiguration.ini file located at C:\dcdsrvr folder and is referred to when trying to do a search.


Or an alternative to this would be to update the same information in the above mentioned file and change the service status for DC Directory to Automatic, start the service. As a personal choice, I'd always recommend running the Plugin again and choosing Uninstall option.


To launch the plugin, you can go to https:///CCMAdmin/install.asp and search for the file called "Cisco Unified CallManager Customer Directory Plugin". If your CM below version CM 4.1, please replace the https with http.


Hope this helps.

E-BRITTON Thu, 08/16/2007 - 08:50
User Badges:

hi carlos,


have you done this:

There are no issues when you view the users from the Cisco CallManager administration pages. As a workaround for this issue, set the value for the LDAP Directory Configuration parameter UserDirAccess to true in the C:\dcdsrvr\Config\UMDirectoryConfiguration.ini file.

Actions

This Discussion