VPN Client - Validation Failed for VSINIT.DLL

Unanswered Question
Jul 16th, 2007

We are currently migrating our machines from a W2K to a W2k3 Forest.

After we migrate a machine, the Cisco VPN Client service cannot start, and fails with error "Failed to Validate C:\Windows\System32\vsinit.dll". (Client version 4.6 and 5.0 are the same).

In the event log, I see 5011 errors from the 'TrueVector' service.

This seems to happen when the DNS Domain Name of the machine is changed.

What's worse is that even a standard re-install of the VPN Client does not help!

Please, can someone tell me how to resolve this issue, it has completely halted my migration project at the moment!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Fri, 07/20/2007 - 10:38

Try these steps. Locate C:\WINDOWS\system32\vsinit.dll, Right click to go on properties page, Go to tab DigitalSignatures.It should say in column -> Zone Labs, Inc, Click on the on Zone Lab, Inc and click details button, Under General tab click on View Certificate Button, Now just click on OK and rest of OK button to come out

WhiteTomR Sun, 07/22/2007 - 23:40

Thanks for the reply.

You're right that it was to do with certificates! In the end, I had to alter Group Policy slightly to affect the certificates the clients were trusting. I had inadvertently set them to only trust enterprise CAs and not trusted root certificates.

Problem is solved now.

ericmaika Thu, 08/14/2008 - 07:48

We have the same message on a Windows XP machine running the VPN 5.0.02.0090. We tried updating the certificates using ROOTSUPD.EXE, and by right clicking on vsinit.dll and installing the certificate in the instructions above. However we are still getting the same error message.

We have also run a virus/spyware scan and it didn't find anything. If you can give me anything else to try fixing the problem it would be appreciated!

Actions

This Discussion