internet access

Unanswered Question
Jul 16th, 2007

hi,

this: my config

interface MFR1

mtu 4470

no ip address

no ip redirects

no ip proxy-arp

ip flow ingress

ip flow egress

encapsulation frame-relay IETF

no ip route-cache cef

ip route-cache flow

no ip mroute-cache

load-interval 30

no arp frame-relay

frame-relay multilink bid xxxxxxx

frame-relay lmi-type ansi

!

interface MFR1.500 point-to-point

ip address x.x.X.x x.X.x.X

no ip redirects

no ip proxy-arp

ip flow ingress

ip flow egress

no cdp enable

no arp frame-relay

frame-relay interface-dlci 500 IETF

!

interface FastEthernet0/0

description xxxxxxx

bandwidth 100000

ip address x.x.x.x x.x.X.x

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip route-cache flow

load-interval 30

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

ip flow ingress

ip flow egress

encapsulation frame-relay MFR1

ip route-cache flow

load-interval 30

no arp frame-relay

!

interface Serial0/2/0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

ip flow ingress

ip flow egress

encapsulation frame-relay MFR1

ip route-cache flow

load-interval 30

no arp frame-relay

sh ver :

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.3(11)T3, RELEASE SOFTWARE (fc4)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Wed 26-Jan-05 02:49 by pwade

ROM: System Bootstrap, Version 12.3(8r)T7, RELEASE SOFTWARE (fc1)

ROM: Cisco IOS Software, 2800 Software (C2800NM-ADVSECURITYK9-M), Version 12.4(3a), RELEASE SOFTWARE (fc2)

XXXXX uptime is 1 hour, 12 minutes

System returned to ROM by power-on

System image file is "flash:c2800nm-advipservicesk9-mz.123-11.T3.bin"

Cisco 2811 (revision 53.51) with 223232K/38912K bytes of memory.

Processor board ID FTX0950C5AC

2 FastEthernet interfaces

2 Serial interfaces

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)

I need to limit the 2XT1 (3Mbit) to 70% of it's bandwidth, how can i do it?

and i want that 1 station will get the highest priority when using the internet.?

how can i implement this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Hi,

If you want to limit the PVC speed and employ some QoS do the following.

1. enable frame-relay traffic shaping on the MFR interface (not the subinterface)

2. Define a class-map to match the desired traffic needs priority

class-map match-any

match access-group

3. Create the acl to define the traffic

4. Create a policy map where you can define how the given class should behave

policy-map

class ce_vpn_6600003_l2l

bandwidth

5. Create a map-class where you can define FR parameters for the PVC

map-class frame-relay

frame-relay cir 2150000

frame-relay bc 21500

frame-relay mincir 2150000

service-policy output

6. Assign the class to the MFR subinterface

traffic which not defined will fall to the default class.

interface MFR1.500 point-to-point

frame-relay interface-dlci 500 IETF

class

You have quite lot options under the policy map (set dscp, RED, WRED) so better to browse Cisco web for more info. The above is to configure CBWQ, but if you have some voip traffic which needs priority better to use LLQ.

Hope it helps,

Krisztian

lepavelcisco Tue, 07/17/2007 - 04:12

hi,

is this reffered to in going or out going traffic? how do i indecate outgoing traffic?

now how can i do:

1. give higtest priority to 2 specipic ip address?

2.how can i limit specipic protocol trafic to specific bandwith let say 80 Kbps?

3. how can i limit session or per user traffic to let say 20 kbps per user or session or connection?

Hi,

The direction is definied under the class-map.

service-policy output/input

1. What kind of traffic you want to give priority? Is it UDP based or TCP?

If UDP (for instance RTP) is being used then the LLQ is the best if TCP the CBWQ is suitable.

For defining the "interesting" traffic use acl. For example to give 80 kbps for telnet traffic from host 192.168.100.10 to any destination:

access-list 111 permit tcp host 192.168.100.10 any eq 21

class-map match-any telnet

match access-group 111

policy-map outbound

class telnet

bandwidth 80

2. You can define multiple classes using class map and define different behavior for each under the policy-map.

3. I think this can not be configured rather it should be configured on the server (for example ftp servers are able to limit the traffic per session and number of simultaneous sessions)

Hope it helps, rate if does

Krisztian

Actions

This Discussion