Problem with IP level of a configuration

Answered Question
Jul 17th, 2007
User Badges:

Hi everybody ! I'm a CNNA student right now and I'm on a problem. Recently I purchased a cisco 1700 router and I configured it with my inet provider data, and It's working. I mean, the remote host give me my public internet address, and everything is fine. The only problem with this is that ;D I can't ping the internet from inside the router and even less from a PC.( I can't access the inet so ) I will attach my config file, that way you can check it and maybe you can help me. I'm thirsty to learn, and If I pass this one it will be great for my experience configuring provider access. Thanks everybody.



Attachment: 
Correct Answer by Edison Ortiz about 9 years 10 months ago

Correct.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (4 ratings)
Loading.
Edison Ortiz Tue, 07/17/2007 - 11:59
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Do you know if you are getting a valid IP from your provider ?


You can verify this IP by typing


show ip interface brief


A routable IP must be listed under ATM0.1


You can also try pinging an internet device by IP instead of name, this way you can isolate a DNS issue - please do so at the router before moving to the workstation level.

godzilla0 Tue, 07/17/2007 - 12:06
User Badges:

Hi ! I think I'll learn a lot from the official forums, what a fast response, thanks ! Look, this is what show ip interface brief dumps :


Interface IP-Address OK? Method Status Protocol

ATM0 unassigned YES NVRAM up up

ATM0.1 89.128.227.208 YES DHCP up up

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

FastEthernet0 192.168.0.1 YES NVRAM up down

NVI0 unassigned YES unset up up


The IP you can see at the ATM0.1 iface is my public inet IP, so I think it's ok. I can't ping outside. And I can tell you this evening, trying with other parameters I succes pinging the inet, even translating with DNS. But I erased it and now I'm like this again . . I can't remember what I exactly did. Thanks again for your support.

godzilla0 Tue, 07/17/2007 - 12:36
User Badges:

You're right ! I did not realize that if the connection it's done by DHCP everything else is auto-assigned too. Now it's working, but I have to ask another question. I have to configure the DNS on my computer to get in to the http, can you tell me how to automatize the DNS name resolving ? Thanks so much for this quick response !

Edison Ortiz Tue, 07/17/2007 - 12:21
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Let's stick with just IP before introducing DNS into the picture.


From the router, try this command:


ping 4.2.2.1 source ATM0.1


and post the result here.

godzilla0 Tue, 07/17/2007 - 12:40
User Badges:

Thank you Edison, I tried what you said and the ping was satisfactory. Can you explain what is that ping to the interface ? Now my problem it's solved but it's interesting to know more. I'm looking to get the DNS working automatically with the hosts that go outside with the 1700 as gateway. Thanks so much.

Edison Ortiz Tue, 07/17/2007 - 12:46
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You need to supply the local devices with DNS information either via DHCP or static.


From the router config, it seems you were provided with 2 DNS servers.


ip name-server 80.58.61.250

ip name-server 80.58.61.254



Enter those IP address at your workstation(s) under DNS and you should be able to browse the internet.


The workstation(s) must have a default gateway of 192.168.0.1 and an IP within the 192.168.0.x subnet.

godzilla0 Tue, 07/17/2007 - 12:50
User Badges:

Ok, thank you very much. So if I want to supply the DNS automatically to the workstations, I have to configure the DHCP server right ? You can't make the machines get the DNS server address if you don't provide them with DHCP so ? Thanks!

Correct Answer
Edison Ortiz Tue, 07/17/2007 - 12:52
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Correct.

mohammedmahmoud Tue, 07/17/2007 - 12:22
User Badges:
  • Green, 3000 points or more

Hi,


Try doing extended ping using the ip address of the fastethernet interface as the source.


HTH,

Mohammed Mahmoud.

mohammedmahmoud Tue, 07/17/2007 - 12:28
User Badges:
  • Green, 3000 points or more

Hi,


Your IP is routable over the internet, more over i can actually ping it:


C:\Documents and Settings\mmahmoud>ping 89.128.227.208


Pinging 89.128.227.208 with 32 bytes of data:


Reply from 89.128.227.208: bytes=32 time=268ms TTL=241

Reply from 89.128.227.208: bytes=32 time=198ms TTL=241

Reply from 89.128.227.208: bytes=32 time=222ms TTL=241

Reply from 89.128.227.208: bytes=32 time=246ms TTL=241


Ping statistics for 89.128.227.208:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 198ms, Maximum = 268ms, Average = 233ms


If you are further having problems, please check the DNS on the router, and the default gateway and dns on the PCs.



HTH,

Mohammed Mahmoud.

Actions

This Discussion