Sip Phone & CCME are in different LAN

Unanswered Question
Jul 17th, 2007

Hello,

CCME and Sip Phone (linksys) are not in the same LAN

And IP adreses are not real (NAT)

Following debug messages

Sent:

SIP/2.0 400 Bad Request - 'Invalid IP Address'

Via: SIP/2.0/UDP 88.230.21.105:5060;branch=z9hG4bK-adf53327

From: 712 <sip:[email protected]>;tag=86ce9cf293dced4ao0

To: 712 <sip:[email protected]>;tag=234B8A4-FAF

Date: Wed, 18 Jul 2007 01:46:40 GMT

Call-ID: [email protected]

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 21737 REGISTER

Content-Length: 0

THANKS

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Tue, 07/17/2007 - 15:17

Hi,

the error is because source and destination of the request are the same. Please include a diagram of all devices involved, how they are connected, addresses and configuration.

rsefer Tue, 07/17/2007 - 22:44

Hi,

Diagram is attached as a .jpeg file

---CME(Virtual IP:192.168.2.2))-----ADSL-NAT(IP:81.214.249.125)------INTERNET-------(IP:88.230.21.105)ADSL-NAT----SIP PHONE(Virtual IP:192.168.0.22)

IOS CONFIG;

!

voice register global

mode cme

source-address 192.168.2.2 port 5060

max-dn 288

max-pool 96

external-ring bellcore-dr3

file text

create profile sync 0005641260332924

!

voice register dn 4

number 712

!

!

voice register pool 4

id mac 0000.0000.0000

number 1 dn 4

max registrations 96

username 712 password 1234

!

!

!

THANKS

Attachment: 
Paolo Bevilacqua Wed, 07/18/2007 - 03:00

Hello,

loks like one or both the ADSL modems have problems in doing NAT correctly. I must tell you that it can be very consuming to fix the issue.

If you could get an ADSL card for the CME router, and possibily a cisco router for the site where is the phone, you would be able to fix everything very easily with a tunnel between the two routers.

Else as I said, it mya take quie a bit of effort and fighting with your ADSL modems.

Hope this helps, please rate post if it does!

rsefer Wed, 07/18/2007 - 08:32

I have eliminate both adsl modems

---CME(Virtual IP:192.168.2.2))-----FORTIGATE FW-NAT-SIP-SUPPORT(IP:81.214.249.125)------INTERNET-------(IP:88.230.21.105)SIP PHONE

NOTHING CHANGES

SAME DEBUG MESSAGES

Paolo Bevilacqua Wed, 07/18/2007 - 08:35

Ok, please capture the full debug message and post it here. That is, the registration message.

rsefer Fri, 07/20/2007 - 15:02

Hi, this is full debug

I am afraid, this is because

CME and SIP Phone are in different LANS?

Attachment: 
Paolo Bevilacqua Fri, 07/20/2007 - 15:49

Hello,

What is 85.99.126.38 ? The packet received from CME request to register to this address that does not belongs to CME.:

Jul 20 22:57:57.316: //-1/xxxxxxxxxxxx/SIP/Error/sipSPI_validate_own_ip_addr: ReqLine IP addr does not match with host IP addr

Either the FW is not configured correctly, or it is introducing the error. If you can expose one router interface to the internet, the phone would register no problem.

rsefer Sun, 07/22/2007 - 09:44

THANK YOU,

I did your recommendation.

and connect one interface to internet directly.

SIP phone (Linksys SPA3102) registers.

I make a call with g711 codec.

But, I cannot talk with g729* codecs

LinkSys support g729a

but Cisco g729r8

Are they compatible?

THANKS

Paolo Bevilacqua Sun, 07/22/2007 - 12:58

Yes they should be compatible.

It get complicated because also the called phone must use the same g729, else you have to configure transcoding that is quite complicated.

Plus you will find that g729 is not well suited for internet where some packet loss and jitter occurs.

Anyway if you watn to tr, do the config on both linksys and router, and send the ccsip trace if it fails.

As an appreciation to those providing answers, please rate all useful posts using the scrollbox below!

Actions

This Discussion