Custom Report from 3.5 to 4.0.4

Unanswered Question
Jul 17th, 2007

I have a custom report that was written for IPCC 3.5. We are upgrading to 4.0.4. From my test on our test 4.0.4 box the custom report does not work.

Will we have to re-write the custom report?

Are there just a few changes we need to make?

Any docs to look at that would help?

Any help would be greatly appreciated.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
wenqianyu Wed, 07/25/2007 - 20:09

How to create SQL Stored Procedure? I tried to create a link between Crystal Report and IPCCX server, and got error "Login failed for user sa. Reason: Not associated with a trusted SQL server connection".

I used sa/sa as UserID/password when configure connection between Crystal Report and IPCC server.

Any idea where went wrong?


ranpierce Thu, 07/26/2007 - 06:00

I ran into the same problem. I opened a TAC case and they had me do a workaround I don't really like but am still using it.

Rename the password of your local administrator on your workstation to the same administrator password as the server that has sql.

Then log on as the administrator to crystal reports. (right click and you will see it)

The reason for this is that the crs server is in a workgroup and not the domain.


wenqianyu Thu, 07/26/2007 - 16:23

Thanks for reply.

I used that way in my wallboard solution. I am hesitating to provide access to reporting person.

The other way to establish link between Crystal Report and SQL is to use Mixed Mode Authentication. That way you can use account sa for authentication. But this is not supported in Cisco.


This Discussion