7906 Phone Load Problems

Unanswered Question
Jul 17th, 2007

Hi,

I am having a very strange problem. I connected a cisco 7906. I have all its files ready in the router.

In telephony-service I have load 7906 term06.default

I extracted cmterm-7911_7906-sccp.8-2-2SR1.tar to flash and made all the files available with the tftp-server flash:/ command.

When I plug in the phone, during bootup, it comes up with a screen saying upgrading, with the mac-address in the bottom and its ip on the upper part. It then fails, registers with Call Manager Express, gives a term06.default.load not found error, and then works fine. I tried to debug tftp events and it goes till loading term06.default.loads.

Could someone please put some light on my problem. I am not exactly sure which files does an IP phone need in normal operation.

Note that I had to hard reset the phone the first time it did this, then it kept giving me this error.

Thanks

Alex

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Wed, 07/18/2007 - 03:02

Hi,

Look again at the "debug tftp events" and configuration, or post it here. You will almost surely find that some file is not sent hence the upgrade fails.

Hope this helps, please rate post if it does!

aseychell Wed, 07/18/2007 - 03:21

It says:

Looking for term06.default.loads

I verified it is actually in flash and in the tftp-server command but nothing.

I removed the load statement from telephony service and now is working fine.

Paolo Bevilacqua Wed, 07/18/2007 - 05:50

Well that means the tftp-server statement is wrong. If it was Ok, you would see "Opening term06.default.loads" immediately after.

aseychell Wed, 07/18/2007 - 22:36

I will check it again when I arrive at work but I am already checked it a couple of times. In tftp-server statement, I need to include the extension no (.loads)?

If possible can you direct me to a link where there is a detailed explanation of the phone load procedure?

Thanks

Hi everyone,

Typically I place the phone firmware in specific directories on the compact flash, in this case the directory is c7911 for the 7911/06.

Therefore my tftp server statements look like the following.

tftp-server flash:/c7911/term11.default.loads alias term11.default.loads

tftp-server flash:/c7911/term06.default.loads alias term06.default.loads

tftp-server flash:/c7911/SCCP11.8-2-2SR1S.loads alias SCCP11.8-2-2SR1S.loads

tftp-server flash:/c7911/jar11sccp.8-2-2ES1.sbn alias jar11sccp.8-2-2ES1.sbn

tftp-server flash:/c7911/cvm11sccp.8-2-2ES1.sbn alias cvm11sccp.8-2-2ES1.sbn

tftp-server flash:/c7911/cnu11.8-2-2ES1.sbn alias cnu11.8-2-2ES1.sbn

tftp-server flash:/c7911/dsp11.8-2-2ES1.sbn alias dsp11.8-2-2ES1.sbn

tftp-server flash:/c7911/apps11.8-2-2ES1.sbn alias apps11.8-2-2ES1.sbn

The telephony-service load statements are,

telephony-service

load 7921 CP7921G-1.0.3.LOADS

load ATA ATA030203SCCP051201A

load 7970 SCCP70.8-2-2SR1S

load 7961 SCCP41.8-2-2SR1S

load 7911 SCCP11.8-2-2SR1S

Don't forget to "create cnf" under telephony-service.

I hope this helps,

Cheers.

Paolo Bevilacqua Thu, 07/19/2007 - 03:20

Hi,

Example given by Leemj001 is perfectly correct and if you follow it should work no problem.

aseychell Thu, 07/19/2007 - 10:06

Thanks for your replies.

So I do not have to use the .default.loads files in the load statements? Why are they present with every firmware version of the phones.

Also, for the 7906 do I need to specify load 7906 or load 7911 (as in the example)?

I am asking so because the only difference there is from the config above and my current config are the fact that I tried load 7906 term06.default instead of load 7911 and that I did not have to use the alias command as the files are in the root of the flash.

Thanks again.

Hi,

yes you are correct you do need specify the 7906 load details, I missed it from the config, my bad.

load 7906 SCCP11.8-2-2SR1S

You don't have to specify the term06.default. The phones automatically look for term06.default.

The reason I specify the load is to ensure that loads the firmware that I want.

This also allows me add updated firmware files to the flash directory and change the load statements at an agreed time with the customer without have the phones upgrade early if they reset.

From a support perspective our customers have always wanted to know how they can confirm what firmware the phones have, so it's easy to look through the config and see mode and firmware version, which should match the firmware on the phone.

I hope this helps.

Regards.

Mike.

aseychell Thu, 07/19/2007 - 22:18

I already tried the above statement but I still have the same error. I will use a windows tftp client to connect to the router and see if I can manage to download the SCCP11.8-2-2SRIS.loads file from the router. If I am successful than it must be something else. Strange thing is I cannot say that it is a phone problem as I have 3 of them giving all the same error. I dont know if I said this already but if I specify the load statement for the 7906, the phone will begin to boot, reset, then a strange screen with the IP of the phone and 'error' written is displayed. It is the same screen that you have when you hard reset the phone. Same problem with 7970 phones. Same kind of screen.

Will keep you posted.

Thanks

aseychell Thu, 07/19/2007 - 23:28

Mmm good point there.

I am going to check if it is a 1 or I.

I will let you know how it goes.

Thanks again,

Alex

Actions

This Discussion