Microsoft NLB on Catalysts 2960 and 3750

Unanswered Question
Jul 18th, 2007
User Badges:

Hi All,


I`ve configured 2 NLB clusters in Multicast Mode.


Cluster 10.0.16.130 (Node1: 10.0.16.131 Node2: 10.0.16.132)


Cluster 10.0.19.2 (Node1: 10.0.19.3 Node2: 10.0.19.4)


I must give network access to these clusters.


One cluster is connected to Catalyst 3750 another to Catalyst 2960.

-----on 3750-----

interface Vlan128

description << NLB1 >>

ip address 10.0.16.129 255.255.255.240

end


interface GigabitEthernet1/0/17

description << NLB1 NODE1 >>

switchport access vlan 128

switchport mode access

duplex full

end

!

interface GigabitEthernet2/0/17

description << NLB1 NODE2>>

switchport access vlan 128

switchport mode access

duplex full

end


arp 10.0.16.130 MAC ARPA

mac-address-table static MAC vlan 128 interface GigabitEthernet2/0/17 GigabitEthernet1/0/17


-----on 2960-----

interface FastEthernet0/11

description << NLB2 NODE1 >>

switchport access vlan 19

switchport mode access


interface FastEthernet0/12

description << NLB2 NODE2 >>

switchport access vlan 19

switchport mode access

!


arp 10.0.19.2 MAC ARPA

mac-address-table static MAC vlan 19 interface FastEthernet0/11 FastEthernet0/12


I can ping all cluster nodes and cluster IP. But in 5 minutes or a bit less it becomes impossible to ping one node of each cluster. Cluster is operational.

After executing "clear arp" on the switch I can again ping both nodes an cluster IP.

What can cause this strange behavior?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dsweeny Tue, 07/24/2007 - 12:29
User Badges:

I think you can ping all cluster nodes and cluster IP at any time. As you know that clear arp command is use to delete a specific entry or all entries from the ARP table.


I think your problem is due to ARP overhead.

Actions

This Discussion