Complex Routing Protocol Redistribution

Unanswered Question
Jul 18th, 2007

Hi Sir,

Please refer to attached network diagram.

I need to configure redistribution such that all routers have full IP reachability to all other routers.

Kindly advise how should I approach the redistribution given this seemingly complex multiprotocol network.

Thank you.

B.Rgds,

Lim TS

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Pavel Bykov Wed, 07/18/2007 - 04:33

All your BGP sessions are eBGP? Are you running different AS on every router?

Also, there is no connectivity between R2 and R6, so it doesn't look like full mesh.

Also, from Diagram it is not clear if there are only connected networks in the routers, or there is something else further away. If there are only connected networks, you can use "redistribute connected" command on every router under BGP process on R2, R5, R6, and then RIP > OSPF and OSPF > RIP redistribution on R7.

Otherwise, if there are other routers, you can use EBGP as a carrier:

R2: RIP > BGP, BGP > RIP

R5: OSPF-0 > BGP, OSPF-25 > BGP, BGP > OSPF-0, BGP > OSPF-25

R6: Static > BGP

R7: RIP > OSPF, OSPF > RIP

limtohsoon Wed, 07/18/2007 - 05:26

Hi,

Thanks for your response.

R2,R4,R5,R6 are connected to frame-relay with full-mesh PVCs between them. They are on a single subnet. I suppose the BGP sessions should be established to each others' frame relay interface IP addresses. Each router is on its own BGP AS.

There are internal routers in the OSPF (areas 0 & 25) and RIPv2 domains. Routers in the "static" domain point a static default route towards R6. FYI, OSPF areas 0 & 25 belong to the same OSPF process.

It appears that mutual redistribution at every boundary routers should accomplish the task. I'm more concerned about controlling the routes being redistributed in order to prevent routing loop.

I don't see any issue redistributing between RIP & OSPF domains because there's only a single boundary router. The tricky part is redistribution between OSPF and BGP where there are 3 boundary routers. How would you recommend the routing loop prevention mechanism? set community (BGP), set tag (OSPF), etc?

Please advise further.

Thank you.

B.Rgds,

Lim TS

limtohsoon Sun, 07/22/2007 - 10:32

Hi,

Attached is another complex scenario (as far as I'm concerned). Again, the objective is to perform redistribution such that all routers have IP connectivity to all other routers. For R2 and R5, RIP routes should be preferred.

I've done the config and it looks fine at first. However after resetting OSPF process on R5,R6 & R7, permanent routing loop forms between R2,R4,R5 & R6.

My method:

R1

--

Redis conn -> OSPF

R2

--

Redis OSPF -> RIP

Redis OSPF -> EIGRP

Redis RIP -> OSPF

Redis RIP -> EIGRP (deny routes with tag 200, else set all routes with tag 100)

Redis EIGRP -> RIP (deny routes with tag 100, else set all routes with tag 200)

Redis EIGRP -> OSPF

R4

--

Redis conn -> EIGRP

R5

--

Redis RIP -> EIGRP (deny routes with tag 200, else set all routes with tag 100)

Redis RIP -> OSPF

Redis OSPF -> RIP

Redis OSPF -> EIGRP (deny routes with tag 400, else set all routes with tag 300)

Redis EIGRP -> RIP (deny routes with tag 100, else set all routes with tag 200)

Redis EIGRP -> OSPF (deny routes with tag 300, else set all routes with tag 400)

R6

--

Redis OSPF -> EIGRP (deny routes with tag 400, else set all routes with tag 300)

Redis EIGRP -> OSPF (deny routes with tag 300, else set all routes with tag 400)

R8

--

Redis RIP -> OSPF

Redis OSPF -> RIP

Please advise how you would approach this scenario.

Thank you.

B.Rgds,

Lim TS

purohit_810 Wed, 07/18/2007 - 05:11

Change configuration according to your subnet and follow syntex.

Router -2

Router bgp 100

redistribut ospf 25

redistribute ospf 1 match internal 1 external 2 {{This is optional but required in your scenario}}

redistribute rip subnet

distribute-list 11 out rip

access-list 11 permit {Subnet and wild card mask}

access-list 11 deny 0.0.0.0 255.255.255.255 {Other than that all will be block}

Router -5

Router bgp 100

redistribut ospf 25

redistribute ospf 0

redistribute ospf 1 match internal 1 external 2 {{This is optional but required in your scenario}}

Router-6

router bgp {Local AS no}

neighbor {Nexp hop IP} remote-as {AS NO}

redistribute static

redistribute ospf 0

redistribute ospf 1 match internal 1 external 2

Router 7:

Router ospf 100

redistribute rip subnet

distribute-list 11 out rip

access-list 11 permit {Subnet and wild card mask}

access-list 11 deny 0.0.0.0 255.255.255.255 {Other than that all will be block}

router rip

default-metric 10

network {Network No}

passive-interface serial 0 { Optional }

passive-interface serial 1 { Optional }

resdistribute ospf 100 match internal 1 external 2

Actions

This Discussion