Problem with LACP or Switch ports?

Unanswered Question

I'm trying to setup LACP (Cisco 6513) on an Apple XServe but I cannot get both ports to be working simultaneously. I have successfully set up the 4 other Xserves but this one will not work. When I do a "sh etherchannel 27 summary" it shows one port in Po27(SU) and the other in Po27B(SU) and it is waiting to be aggregated.


I can get each port to work fine on a Catalyst 2950, the server's motherboard and NIC's have been swapped out to test, and other servers work fine on the ports, just not this server.


At this point we have no idea where to go but are convinced the problem has to come from the switch somewhere.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Wed, 07/18/2007 - 08:07
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If you connect the same 2 links on another server, does it work ?


If you move the problem server to a LACP group that works, what happens ?


Posting your config will sure help !

Edison Ortiz Wed, 07/18/2007 - 10:58
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Port 39 is working, the problem seems to be with Port 40. Can you change the mode to active on both links ?


I suggest doing a shut/no shut on each link to isolate any down state due to err-disable.

glen.grant Wed, 07/18/2007 - 18:32
User Badges:
  • Purple, 4500 points or more

I too would think it would either have to be forced on or at least "active" , not passive. what was the 2950 config ,they should be identical as channels are setup the same way on both .

Edison Ortiz Thu, 07/19/2007 - 07:21
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

passive/passive won't work. One side needs to be active. Can you remove the lacp command from the interfaces ? The 'mode active' will take care of the etherchanneling LACP mode.

Actions

This Discussion