6500 service-policy to trust voice and mark PC traffic to 0.

Unanswered Question
Jul 18th, 2007

I came up with the config below to trust the DSCP markings our Avaya IP phones have, and to make sure that all traffic from the PC plugged into the IP phone is marked to 0. Since Avaya doesn't do CDP and LLDP is not mature enough - nor is it available on the 6500 yet, I need to have the 6500 access layer switch do the re-marking of PC traffic

The config below works just fine after testing and sniffing the traffic.

Would you please look it over and see if there are any gotcha's and/or pit falls with using this method. Am I painting myself into a corner?

class-map match-all Trust_phone_DSCP

match access-group 171

class-map match-all Mark_PC_traffic_to_0

match access-group 161

!

!

policy-map Mark_PC_traffic_DSCP=0

class Mark_PC_traffic_to_0

set dscp default

policy-map Trust_phone_DSCP

class Trust_phone_DSCP

trust dscp

interface GigabitEthernet1/1

description IP phone & PC

switchport

switchport access vlan 17

switchport mode access

switchport voice vlan 910

no ip address

speed 100

duplex full

mls qos vlan-based

spanning-tree portfast

interface Vlan17

ip address 154.88.17.1 255.255.255.128

ip helper-address xxx.xxx.xxx.xxx

ip pim sparse-mode

load-interval 30

service-policy input Mark_PC_traffic_DSCP=0

interface Vlan910

ip address 172.19.17.1 255.255.255.128

ip helper-address xxx.xxx.xxx.xxx

service-policy input Trust_phone_DSCP

access-list 161 permit ip 154.88.0.0 0.0.255.255 any

access-list 171 permit ip 172.19.0.0 0.0.255.255 any

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion