857 dhcp config

Unanswered Question
Jul 18th, 2007

Hi there, I recently purchessed a Cisco 857 router as a replacement to my old router which stopped working. As I'm totally new to Cisco I'm having big problems trying to get it up and running.

Through the initial config I tried to configure it via SDM Express but had major problems, especially with my adsl config!

I later discovered this site:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a601.shtml

but through the intial command: Router#write erase

managed to erase all the initial config so now after trying to manually set things up through IOS, I'm unable to configure the dhcp server to lease ip addresses!

Through looking at posts on this forum I managed to find this site: http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca75c.html

which I guess got me a little closer but still not working. Could someone suggest something?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
guruprasadr Wed, 07/18/2007 - 20:39

HI, [Pls Rate if HELPS]

Configuring Cisco Router as DHCP Server:

-------------------------------------------

Only a few steps required:

ip dhcp pool POOLNAME

network "Subnet address" "Mask"

default-router "GW address"

Info: you need an interface which is configured with the GW address.

Refer LINK Below:

---------------------

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008743b.html#wp18061

Pls Rate if HELPS

Best Regards,

Guru Prasad R

mohammedmahmoud Thu, 07/19/2007 - 01:32

Hi,

If you would like, please past the configuration, and please clarify the problem you are facing with it.

HTH,

Mohammed Mahmoud.

kayasaman Thu, 07/19/2007 - 02:31

Ok, I've used the commands:

Router(config)#ip dhcp pool dpool1

(and accidentaly created another one called dhcppool)

then Router(config-dhcp)#network 192.168.1.0 255.255.255.0

Router(config-dhcp)#import all

Here is the dhcp pool config:

Cisco#show ip dhcp pool

Pool dpool1 :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 0

Leased addresses : 0

Pending event : none

0 subnet is currently in the pool

Pool dhcppool :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254

Leased addresses : 0

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

192.168.1.1 192.168.1.1 - 192.168.1.254 0

Also running config if helps:

Current configuration : 2254 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco

!

boot-start-marker

boot-end-marker

!

enable secret 5 ****************

!

no aaa new-model

!

resource policy

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.9.0

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool dpool1

import all

dns-server 192.168.35.2

domain-name cisco.router

netbios-name-server 192.168.2.254

default-router 192.168.1.1 255.255.255.0

lease infinite

!

ip dhcp pool dhcppool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

ip cef

no ip domain lookup

ip domain name cisco.router

ip name-server 192.168.11.12

!

!

!

!

!!

!

!

interface Loopback0

ip address 10.108.1.1 255.255.255.0

!

interface ATM0

ip address 200.x.x.1 255.255.255.0

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

!

interface Vlan1

no ip address

ip nat inside

ip virtual-reassembly

!

interface Dialer0

ip address negotiated

ip mtu 1400

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp chap hostname ******

ppp chap password 0 *****

ppp pap sent-username ***** password 0 *****

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

no ip http server

no ip http secure-server

ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source list ac11 pool pool1

!

no ip http secure-server

ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source list ac11 pool pool1

!

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

exec-timeout 5 30

password *****

login

no modem enable

line aux 0

line vty 0 4

password *******

login

!

scheduler max-task-time 5000

end

I basically would like to setup a dhcp server on the fastethernet interfaces 0-3 so when I plug a client in the ip address is given to the client from the router and also I would like the default gateway ip to be 192.168.1.1. Through my own config my clients card doesn't obtain an ip and XP just comes out with: "limited or no connectivity to network"

However link status is up at 100Mbs!

kayasaman Thu, 07/19/2007 - 02:38

Also I would like to remove the pool: dhcppool or rename it to dpool1 as I would like this to be primary dhcp pool!

guruprasadr Thu, 07/19/2007 - 02:51

Hi, [Pls Rate if HELPS]

On Verifying your DHCP Pool Configuration:

ip dhcp pool dpool1

import all

dns-server 192.168.35.2

domain-name cisco.router

netbios-name-server 192.168.2.254

default-router 192.168.1.1 255.255.255.0

lease infinite

!

ip dhcp pool dhcppool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

Remove Pool: dhcppool

------------------------

Command as below:

-------------------

no ip dhcp pool dhcppool

no network

no default-router

Cofiguration for pool:dpool1

-------------------------------

ip dhcp pool dpool1

import all

dns-server 192.168.35.2

domain-name cisco.router

netbios-name-server 192.168.2.254

default-router 192.168.1.1 255.255.255.0

lease infinite

INFO:"network" command is missing in the Configuration.

Insert the command as below:

-----------------------------

Enter the DHCP dpool1 mode:

Syntax: network network-number [mask | prefix-length]

Eg's:network 192.168.1.0 255.255.255.0

Refer the Link below for further assistance:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_r/iprprt1/1rddhcp.htm

PLS RATE if HELPS

Best Regards,

Guru Prasad R

kayasaman Thu, 07/19/2007 - 03:10

Thanks for that I got 1 problem sorted but the core porblem of the router not giving my client an ip address still remains!

The dhcp config is as follows:

Pool dpool1 :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254

Leased addresses : 0

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

192.168.1.1 192.168.1.1 - 192.168.1.254 0

How do I get the router to give my client an ip address now?

mohammedmahmoud Thu, 07/19/2007 - 03:36

hi,

Please add the ip address of your default gateway to be the ip address of interface vlan 1:

interface Vlan1

ip add 192.168.1.1 255.255.255.0

HTH,

Mohammed Mahmoud.

guruprasadr Thu, 07/19/2007 - 04:05

HI, [Rate all Helpful Replies]

yes, Sorry i missed this.

Since all your Host are in Single VLAN ie., in VLAN1 so Router ip of VLAN1 and Default Router address of DHCP Pool should be same.

Configure as:

interface vlan1

ip address 192.168.1.1 255.255.255.0

Thanks Mohammed for Quick Highlight.

PLS RATE all HELPFUL Replies

Best Regards,

Guru Prasad R

kayasaman Thu, 07/19/2007 - 23:07

Thank you so much guys I know have dynamic ip addresses!

One more question though:

I would like to use SDM aswell as IOS, so I enabled the http server by using the command:

Router(config)#ip http server

However when I try to access the router through SDM it asks for a username and password which haven't been set I'm guessing. So the question is how to setup so I can use SDM?

mohammedmahmoud Thu, 07/19/2007 - 23:22

Hi,

I am glade that you now have it running, to have your SDM running add a username to the router:

username <> privilege 15 password <>

Basic Router Configuration using SDM

http://www.cisco.com/en/US/products/sw/secursw/ps5318/products_configuration_example09186a008073e067.shtml

Configure Your Router to Support SDM

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_installation_guide09186a00803e4727.html#wp70999

HTH,

Mohammed Mahmoud

guruprasadr Thu, 07/19/2007 - 23:22

HI,

Use the below commands:

----------------------------

Router(config)#ip http server

Router(config)#ip http authentication local

Router(config)# username privilege 15 password 0

Open the Web browser and enter the IP Address of the Router Interface connecting the LAN network:

https://LAN-IP-address

PLS RATE if HELPS

Best Regards,

Guru Prasad R

kayasaman Sun, 07/22/2007 - 12:07

Great, thanks again!

Only 2 more issues seem to have arrisen now.

1. How to create a MAC address filter list for the WLAN.

Through SDM I went to Wireless services and Filters, then created a new filter index and added my MAC address using the convention xxxx.xxxx.xxxx and the mask 0000.0000.0000 - Action Forward

The default action I told to forward all as I was not quite sure if it meant forward all in Filter Classes box or if it meant forward everything else??

After that I went to Wireless Security and SSID manager and selected Open Authentication with MAC Address Authentication.

By doing that my computer was locked out of the WLAN, what am I missing?

2. Configuring my adsl connection, I read this article:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a601.shtml

but after inputing all the settings from my ISP as soon as I connect the cable it doesn't connect? Here is my new router config:

Current configuration : 4312 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

!

resource policy

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool dpool1

import all

network 192.168.1.0 255.255.255.0

dns-server 192.168.1.1

domain-name cisco.router

default-router 192.168.1.1

!

!

ip cef

ip domain name cisco.router

!

!

crypto pki trustpoint TP-self-signed-1113224849

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1113224849

revocation-check none

rsakeypair TP-self-signed-1113224849

!

!

crypto pki certificate chain TP-self-signed-1113224849

certificate self-signed 01

3082024A 308201B3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 31313133 32323438 3439301E 170D3037 30363239 30313532

31325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31313332

32343834 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100D929 C90B42F7 61D2E08D 776AC867 EB99BFF8 EE65F8E1 65396E08 5AF0019A

B9C6948C 7B6B783A D8E06A79 169C17C0 953B5B87 8BA3814E 8041114F 12AD426C

770A9DCA 6D7BFFFA 1982CCA1 7BAEE239 A31B5D19 4D78E823 D6BCFBB1 3C63B686

F869B041 EF16A60C FB201943 A9A25227 3481E5BA 03677783 8B0E4FD1 1D4D9361

39110203 010001A3 72307030 0F060355 1D130101 FF040530 030101FF 301D0603

551D1104 16301482 12436973 636F2E63 6973636F 2E726F75 74657230 1F060355

1D230418 30168014 E5952AC7 9D9ADEC7 277BEBB1 18C3626C CC334E17 301D0603

551D0E04 160414E5 952AC79D 9ADEC727 7BEBB118 C3626CCC 334E1730 0D06092A

864886F7 0D010104 05000381 8100B781 68AE959A E41D7CA6 CA11CAF8 28982F55

3B9AFF32 A05AF203 D2D5DA2F CE420DEE 9D589DD8 CAAD0052 840C2AFE 11230C72

374482E8 9653AD6D 56AB4D83 1FD9DDF9 F6F6F476 43D05DCF 6417DB66 1B268F23

26E80CA0 87B05670 95088822 57827224 57953153 3AD1A875 5D5F2DA0 AEA08288

2B579C12 09B34F40 7A9FA70E 5C3F

quit

username ***** privilege 15 password 0 *******

!

!

!

bridge irb

!

!

interface Loopback0

ip address 10.108.1.1 255.255.255.0

!

interface ATM0

description $ES_WAN$

ip address 200.x.x.1 255.255.255.0

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

ssid ******

vlan 1

authentication open

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

l2-filter bridge-group-acl

kayasaman Sun, 07/22/2007 - 12:08

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no snmp trap link-status

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

bridge-group 1

!

interface Dialer0

ip address negotiated

ip mtu 1400

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname [email protected]

ppp chap password 0 mypassword

!

interface BVI1

description $ES_LAN$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255

ip nat source list 1 interface Dialer0 overload

ip nat inside source list 100 interface Dialer0 overload

!

access-list 100 remark SDM_ACL Category=2

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

access-list 700 permit 0012.f00e.3877 0000.0000.0000

access-list 700 permit 0000.0000.0000 ffff.ffff.ffff

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

password ********

login

no modem enable

line aux 0

line vty 0 4

access-list 100 remark SDM_ACL Category=2

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

access-list 700 permit 0012.f00e.3877 0000.0000.0000

access-list 700 permit 0000.0000.0000 ffff.ffff.ffff

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

password ******

login

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

kayasaman Tue, 07/24/2007 - 03:10

Ok I managed to figure out the MAC address filtering, even though I don't understand why open authentication with MAC address is different from MAC address filtering. I still can't get my adsl connection to work though and any help with that would be apprieciated!

kayasaman Wed, 07/25/2007 - 12:50

Thanks for the advice and to everyone that helped me set up the dhcp server!

I've taken my wan problem over to the WAN/Routing/Network

part of the forum as I think it's better placed there. I'm almost through it and now just need to get pc's to access web through router.

It's hard work being a newbie again, reminds me of when I started out with linux :-)

Regards

Kaya

Actions

This Discussion