Edison Ortiz Thu, 07/19/2007 - 07:40

Change the channel-groups to mode 'on'.

If the VMWare NIC supports LACP, then you can use mode 'active'.

Your current mode is 'auto' and it expects the other end to have 'desirable' which is Cisco's PAgP.

damrut5763 Thu, 07/19/2007 - 08:55

According to the Vmware engineer it should be set to auto for the VLAN tagging. Not sure if the NIC supports LACP, however I can't ping the NIC interface on the server.

Edison Ortiz Thu, 07/19/2007 - 11:45

The channel-group on the cisco side is not for Vlan tagging but to denote the etherchanneling mode.

I wouldn't argue with a VMWare engineer on how to configure their products, but you are asking for Cisco configuration help and I'm giving it to you.

If you want some written explanation, feel free to read:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12237se/scg/swethchl.htm#wp1275779

As for pinging the server NIC, I don't see any Layer3 information on the config you posted but you should be able to ping since the ports are in forwarding mode and up/up - just not bundled on a channel.

I see you have vlan 1,20,21,25 on the trunks, do you have the same vlans created in the VMWare server ?

What Vlan are you trying to ping ?

Can you post the 'show vlan' and 'show ip int brief' from the switch ?

damrut5763 Thu, 07/19/2007 - 11:51

I thank you for all your assistance the VLAN thatthe server is on is 21, VLAN 25 is the iCSI connection. So from your standpoint all is well and it doesn't have to be bundled.

Edison Ortiz Thu, 07/19/2007 - 12:06

Bundling is for aggregation purposes, you can still connect via one link and shouldn't affect your ping process.

Can you please post the output I requested in the previous post ?

Edison Ortiz Thu, 07/19/2007 - 18:37

Thanks for posting the information I requested. Vlan25 does not contain any L3 information, is that one of the Vlans you are trying to ping ?

What address are you trying to ping and where are you pinging from ?

Can you also post the command from 'show int trunk' ?

damrut5763 Fri, 07/20/2007 - 03:28

I'm not trying to ping anything on VLAN 25 that is layer 2, I was trying to ping the server address of 10.1.21.30,31,32 which resides on VLAN 21. I'm pinging from the 6513 switch.

Attachment: 
Edison Ortiz Fri, 07/20/2007 - 06:02

The Cisco side looks fine. Vlans are created in L2 and L3 - they are being forwarded via the trunk interfaces w/o problems.

I believe the problem is at the VMWare side.

If you have another switch, you can verify your trunking is fine. Connect the switch to one of those ports and create Vlans 20,21,25 on that switch, then a SVI for Vlan 21 - assign an IP and you will be able to ping across the trunk (switch-to-switch).

damrut5763 Fri, 07/20/2007 - 06:40

Thank you i have a problem when i just have one port in the trunk/channel-group it works fine but when i add the others i get this error.

Jul 20 14:19:40.347: %EC-SP-5-CANNOT_BUNDLE2: Gi13/36 is not compatible with Gi12/36 and will be suspended (vlan mask is different)

Jul 20 14:19:40.767: %EC-SP-5-CANNOT_BUNDLE2: Gi13/37 is not compatible with Gi12/36 and will be suspended (vlan mask is different)

Jul 20 14:19:41.179: %EC-SP-5-CANNOT_BUNDLE2: Gi13/38 is not compatible with Gi12/36 and will be suspended (vlan mask is different)

Jul 20 14:19:47.367: %SYS-5-CONFIG_I: Configured from console by drutledge onvty3 (10.1.15.64)

Jul 20 14:21:29.060: %EC-SP-5-CANNOT_BUNDLE2: Gi13/33 is not compatible with Gi12/36 and will be suspended (flow control send of Gi13/33 is on, Gi12/36 is off)

Jul 20 14:21:29.260: %EC-SP-5-CANNOT_BUNDLE2: Gi13/34 is not compatible with Gi12/36 and will be suspended (flow control send of Gi13/34 is on, Gi12/36 is off)

Jul 20 14:21:29.460: %EC-SP-5-CANNOT_BUNDLE2: Gi13/35 is not compatible with Gi12/36 and will be suspended (flow control send of Gi13/35 is on, Gi12/36 is off)

Jul 20 14:21:31.115: %SYS-5-CONFIG_I: Configured from console by drutledge onvty3 (10.1.15.64)

Jul 20 14:22:47.558: %EC-SP-5-CANNOT_BUNDLE2: Gi13/33 is not compatible with Gi12/36 and will be suspended (flow control send of Gi13/33 is on, Gi12/36 is off)

Jul 20 14:22:47.762: %EC-SP-5-CANNOT_BUNDLE2: Gi13/34 is not compatible with Gi12/36 and will be suspended (flow control send of Gi13/34 is on, Gi12/36 is off)

Jul 20 14:22:47.970: %EC-SP-5-CANNOT_BUNDLE2: Gi13/35 is not compatible with Gi12/36 and will be suspended (flow control send of Gi13/35 is on, Gi12/36 is off)

Edison Ortiz Fri, 07/20/2007 - 06:58

When you bundle ports, they must be identical in configuration.

What channel-group mode are you configuring the ports under ?

Can I see your latest config ?

Edison Ortiz Fri, 07/20/2007 - 07:14

Can you type

show mod

along with

show int GigabitEthernet12/36 thru /38

and GigabitEthernet13/33 thru /35.

I recommend removing the spanning-tree portfast from those ports.

Actions

This Discussion