sh mac-address table shows learned addresses as STATIC

Unanswered Question
Jul 19th, 2007

When I do a "sh mac-address table" I get see type STATIC when I know the address was learned dynamically by the switch.

The only thing that is learned DYNAMIC is stuff through a trunk.

I'm sure there's a simple explanation why the addresses are labeled this way but it's very confusing.

IT-XXX-XX-03#sh mac-address-table

Vlan Mac Address Type Ports

16 0009.6b2f.633f STATIC Gi0/5

242 001a.a125.27ba STATIC Gi0/5

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Akhilbindal Thu, 07/19/2007 - 08:09

Hi Scott,

If u can send the running configuration of this port then this can be checked..also are u using commands like port-security,etc..and what kind of devices are these whose MAC address is learned on this interface..

Regards

Akhil

scottpickett Thu, 07/19/2007 - 08:17

This is a standard access switch. The devices are both phones and PCs. And I have port-security and several standard "safety features."

XX-XXX-XX-03#sh run in gi 0/5

!

interface GigabitEthernet0/5

switchport access vlan 16

switchport mode access

switchport voice vlan 242

switchport port-security maximum 5

switchport port-security

switchport port-security aging time 1

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

end

scottpickett Thu, 07/19/2007 - 08:22

That's the documentation that I found while researching this question too. The confusing part is that these entries were not statically added by a human.

Akhilbindal Thu, 07/19/2007 - 08:27

Hmm..that is strange..can u pls send the output of the show mac-add command and also running config..of any other interface that has dynamic enteries next to it..

scottpickett Thu, 07/19/2007 - 08:41

I can't send all of the switch config since it's company confidential information, but I can say that the sh mac-address-table output shows STATIC for any address learned through an ACCESS port and DYNAMIC for any address learned through a TRUNK. The switch is a 3560.

Thanks!

Akhilbindal Thu, 07/19/2007 - 09:01

ok.. is that true for any other access port u have other than this port on the switch..?

scottpickett Thu, 07/19/2007 - 09:15

Yep. Any access port shows the mac-addresses learned on it as static. The only dynamic are addresses learned via trunks (0/27 and 0/28).

Akhilbindal Thu, 07/19/2007 - 13:38

I would recommend you to refresh the MAC Add Table and try and then you can try removing port security command from any access port..and then check..

jimmytango Tue, 07/24/2007 - 23:42

I think static/dynamic status you see refering to how you set the switchport mode. Dynamic means you set the port to negotiate wheter it wants to be trunk or access mode(dynamic desirable i think ??), and static means you configured the port to be access or trunk. Try remove the switchport mode access command to see whether the port status change to dynamic.

Actions

This Discussion