Multiprotocol Configuration

Unanswered Question
Jul 19th, 2007

Hi Sir,


I'm configuring a router which is in the boundary of EIGRP and OSPF. Interface Fas0/0 should be EIGRP network and Se0/0 should be OSPF network.


!

int fas 0/0

desc *** EIGRP Network ***

ip address 150.50.1.1 255.255.255.0

!

int s 0/0

desc *** OSPF Network ***

ip address 150.50.2.1 255.255.255.0

!


I'll be performing mutual redistribution between these two protocols. Is it a good practice to cover one interface with overlapping routing protocols? E.g.


!

router eigrp 100

network 150.50.0.0

passive-interface se0/0

!

router ospf 100

network 150.50.2.1 0.0.0.0 area 0

!


Or should I be more explicit? E.g.


!

router eigrp 100

network 150.50.1.1 0.0.0.0

!

router ospf 100

network 150.50.2.1 0.0.0.0 area 0

!


Please advise.



Thank you.


B.Rgds,

Lim TS


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Thu, 07/19/2007 - 18:20

The first option will enable EIGRP on both interfaces therefore the second option is the correct one. Don't forget to disable the classful default behavior within EIGRP and change it to classless with the 'no auto-summary' command.

limtohsoon Thu, 07/19/2007 - 22:18

Hi Edison,


Thanks for your response.


Sure, will add the "no auto-summary" command under EIGRP. I just didn't show it in my post.


I'm preparing for the CCIE lab exam this year. I just wanna know the best practices, whether an interface should be covered by multiple routing protocols or not.


If my scenario uses RIP instead of EIGRP, then we can't avoid overlapping both RIP and OSPF on interface Se0/0 due to the classful nature of RIP's network command.


Please advise further.



Thank you.


B.Rgds,

Lim TS


mohammedmahmoud Thu, 07/19/2007 - 22:41

Hi Lim,


No problem should arise, except that you should care for 2 things, first the overhead RIP traffic which will be sent over the unwanted interface, and this can be avoided by making this interface passive interface, the second thing is that if you don't want the address of the unwanted interface to be advertised and this can be avoided via route filtering.


Good luck in your CCIE preparations :)


HTH,

Mohammed Mahmoud.

Edison Ortiz Fri, 07/20/2007 - 05:29

First, best of luck obtaining your CCIE.


Second, the best practice when enabling a routing protocol is trying to specify the intended interface as close as possible.


Personally, I always use a host network entry under the routing protocol. I've seen other CCIE candidates using the same subnet mask as the one used in the interface. Either way should work.


For instance,


router ospf 1

network 192.168.1.0 0.0.0.255 area 0


or


router ospf 1

network 192.168.1.1 0.0.0.0 area 0


To answer your question, an interface should be running only one routing protocol. In case of RIP, you can disable the interface from running RIP, if not intended, with the passive interface command.

Actions

This Discussion