High Jitter on outbound calls via 3845 Voice Gateway

Answered Question
Jul 19th, 2007

We recently upgraded our primary voice gateway from an MGCP 2821 running 12.4(7e) to an H.323 3845 running 12.4(11)T2. The same port on the switch, same cables, and same PRI lines were used. Immediately afterwards, we began experiencing high jitter for outbound calls. Before it was 0 - 2 ms, now it is 14 - 16 ms on average. Call quality is still for the most part fine, however rarely a user will sometimes have a call cut in and out of silence. This seems to happen usually on conference calls. Pulling up their phone stats I see a high number of Rcvr Discarded packets (like 100+ per call) and a low MoS score of 2.00. On incoming calls, all stats are great and MoS is 4.5. G.711 is used in both directions.

This happens whether the phone is a 7940 or 7941. However, if I do the exact same call using IP Communicator, Jitter stats are much better. This I can't explain.

Also, I took the old 2821, converted it to H.323 and upgraded IOS to 12.4(11)T2, and placed it on the same switch. Its average jitter for an outbound call was 1 - 2 ms in all test calls.

The 3845 has 4 PVDM-64s installed, while the 2821 has 3 PVDM-32s. Ideas?

I have this problem too.
0 votes
Correct Answer by Stoyan Stoitsev about 9 years 3 months ago
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
johnnylingo Fri, 07/20/2007 - 10:11

Figured this out...I observed the Rcvr Discarded numbers increased when the caller was talking, and concluded that VAD must be enabled. Indeed, I was missing the "no vad" statement from the Dial Peer that handles outbound calls.

Interesting that this would cause problems. The max jitter on these calls never got above 20. Fortunately this is a campus network and we don't need VAD anyway.

shikamarunara Mon, 07/23/2007 - 09:55

I think VAD causes more problems than it solves. I rarely see it being used, most people would rather resort to oversubscription of a line than use VAD to save bandwidth.


johnnylingo Tue, 07/24/2007 - 09:29

Yeah, having VAD enabled on my part was purely unintentional. The thing is, I always thought VAD would be negotiated by CallManager for outbound calls, and with G.711 it was disabled. But obviously is not correct. My config was:

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8


voice class h323 1

h225 timeout tcp establish 3


dial-peer voice 1 voip

description Outbound from VoIP

voice-class codec 1

incoming called-number .

ip qos dscp cs3 signaling


dial-peer voice 400 voip

description Inbound to VoIP

destination-pattern ^[1-8]...$

voice-class codec 1

voice-class h323 1

session target ipv4:

dtmf-relay h245-alphanumeric

ip qos dscp cs3 signaling

no vad


VAD was disabled for incoming calls, but enabled for outbound, even when using G.711


This Discussion