Unanswered Question
Jul 19th, 2007


We are creating two VLAN with a 1800 series router for two branch office each 64 Kbps(Total 128 Kbps).Can Any one tell me the configuration command for creating the VLAN for the above.

Thanks in Advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
csco10983028 Thu, 07/19/2007 - 23:28


I have two VLANs connected to 1841 router.The WAN link is totally 128KBps. I want to dedicately allocate 64KBps for each VLAN. Is there any configuration command for the above scenario?

mohammedmahmoud Thu, 07/19/2007 - 23:36


You can configure QoS on the internet link that matches on the separate VLAN subnets and guarantees 64K for each (but the problem is that this will control the upload only, you'll need the provider to do the same on his side to control the download), or you can do CAR (policing) on the VLAN interfaces.


Mohammed Mahmoud.

guruprasadr Fri, 07/20/2007 - 01:02

HI Mohammed,

Your Reply post is Quiet Interesting.

I am aware that QOS Configuration on our Internet Router will control the Upload speed and we need Service Provider to implement the QOS on thier side to Control the Download.


Can you please post some sample Configuration with Examples of 2-3 VLans and allocate the Guarantee Bandwidth for the each VLAN ? ?

Best Regards,

Guru Prasad R

csco10983028 Fri, 07/20/2007 - 03:52

I do have the same as guru has. can u tell me the link for the configurations.

royalblues Fri, 07/20/2007 - 05:23


What Mohammed is suggesting is to create class-maps that matches the VLAN subnet and apply qos as per your requirements

ip access-list exrended vlan1

permit ip any

ip access-list exrended vlan2

permit ip any

class-map match-all vlan1

match access-group vlan1

class-map match-all vlan2

match access-group vlan2

policy-map restrict

class vlan1

police cir 64000 confirm-action-transmit exceed-action-drop

class vlan2

police cir 64000 confirm-action-transmit exceed-action-drop

interface serial 1/0

service-policy output restrict



guruprasadr Fri, 07/20/2007 - 05:39

HI Narayan,

I was wondering how the configuration would be.

Thanks for the Sample Configuration.

Best Regards,

Guru Prasad R

mohammedmahmoud Fri, 07/20/2007 - 06:54


Narayan's example is a nice example for what i've meant, after doing the classification part you can go for policing or shaping or what ever QoS tool that fits your needs.


Mohammed Mahmoud.

csco10983028 Mon, 07/23/2007 - 02:29


Can this be configured for 1812/1841 router? If so can you send me the link?




This Discussion