877 vlans routing

Answered Question
Jul 20th, 2007

Hi to all,

I have this problem, I need to connect a small office to adsl and to external LAN. So if I have a router with two ethernet (like 28xx) it's easy I put a "static route", but I can not permite a 28xx!!!

So I ask you: can I use a 877? Can I configure more than vlan on its 4 fastEth port? Use 1 port for a vlan and use it as external porta and the other 3 Eth for the default vlan as internal, associate to each of this vlans different IP address and put two static router?

If it is possible con you suggest some configuration or examples?

Thank you.

Augusto.

Correct Answer by mohammedmahmoud about 9 years 7 months ago

hi,


All that you've stated is correct except that you don't need static routes as the interfaces are directly connected on the same router, but you'll need a default route for the internet pointing to the ADSL.


Router# vlan database

Router(vlan)# vlan 2

Router(vlan)# exit


Router#config t


interface FastEthernet0

switchport mode access

switchport access vlan 2


interface FastEthernet1

switchport mode access


interface FastEthernet3

switchport mode access


interface FastEthernet4

switchport mode access


interface vlan1

ip address


interface vlan2

ip address



HTH,

Mohammed Mahmoud.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
purohit_810 Fri, 07/20/2007 - 10:11

Istead of putting two different route... Put Default route.


As of your scenario it is atub network. So, you are good to do that.


U can create Vlan Maximum 4 Vlan.




Regards,

Dharmesh Purohit

Correct Answer
mohammedmahmoud Fri, 07/20/2007 - 11:28

hi,


All that you've stated is correct except that you don't need static routes as the interfaces are directly connected on the same router, but you'll need a default route for the internet pointing to the ADSL.


Router# vlan database

Router(vlan)# vlan 2

Router(vlan)# exit


Router#config t


interface FastEthernet0

switchport mode access

switchport access vlan 2


interface FastEthernet1

switchport mode access


interface FastEthernet3

switchport mode access


interface FastEthernet4

switchport mode access


interface vlan1

ip address


interface vlan2

ip address



HTH,

Mohammed Mahmoud.


Actions

This Discussion