Cisco 857 adsl connection problems

Unanswered Question
Jul 24th, 2007

Hi guys, first up I would like to say thanks for sorting out my dhcp issues in the getting started with LANS part of the forum!

I have an issue now with my adsl connection. I have set up the dialer 0 and atm 0 interfaces according to this guide:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a601.shtml

and have supplied my ISP settings:

VPI 0

VCI 38

Encapsulation VC/MUX or VC Based

Protocol PPPoA

Mode G.DMT

Authentication CHAP

Preferred MTU 1500 (or as close to as possible)

I have supplied my config as txt file.

Again I'm very new to Cisco so please take things step by step.

Many thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
kayasaman Tue, 07/24/2007 - 04:46

Sorry....... issue is that it's not connecting to ISP and I have no internet access :-(

kayasaman Tue, 07/24/2007 - 05:41

Here are the outputs of the atm pvc and debug ppp. I typed in term mon but it didn't come up with anything so I'm guessing it turned on terminal monitor or something?

(again I'm brand new to Cisco so I'm having to learn step by step!)

Attachment: 
Paolo Bevilacqua Tue, 07/24/2007 - 05:46

Hi, PVC 0/38 does not receive packets. Please check that you have the right number, and the ADSL port is connected, do check "show dsl interface". And yes, "term mon" enables the telnet terminal to monitor debug and other system events.

kayasaman Tue, 07/24/2007 - 06:07

It says: line has not been activated yet

I didn't put any config into the atm0 interface interms of pvc, chap authentication, mtu, and line encapsulation, as all my ISP data went to the dialer0 interface which I thought dialled through the atm0. If I am mistaken then will I have to rebuild the atm0 interface with the info from the dialer0 interface?

kayasaman Tue, 07/24/2007 - 07:38

Ok rectifying my statement since I think I'm getting myself confused: "I didn't put any config into the atm0 interface interms of pvc, chap authentication, mtu, and line encapsulation"

I used these commands:

Router(config)#interface atm 0

Router(config-if)#pvc

Router(config-if-atm-vc)#encapsulation aal5mux ppp dialer

Router(config-if-atm-vc)#dialer pool-member 1

Router(config-if-atm-vc)#no shut

Router(config-if-atm-vc)#end

Router#configure terminal

Router(config)#interface dialer 1

Router(config-if)#ip address negotiated

Router(config-if)#no ip directed-broadcast

Router(config-if)#ip nat outside

Router(config-if)#encapsulation ppp

Router(config-if)#dialer pool 1

Router(config-if)#ppp chap hostname

Router(config-if)#ppp chap password

#Router(config-if)#ppp pap sent-username password # I excluded this one!

Router(config-if)#end

Router#configure terminal Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1 Router(config)#end

Router#configure terminal Router(config)#ip nat inside source list 1 interface dialer1 overload

As for my line, it works fine with an ordinary consumer modem - so I really don't know where the problem is :-(

Paolo Bevilacqua Tue, 07/24/2007 - 07:43

Hi, that is all good, you also need "ppp authentication chap callin" under "in dialer1" and "ip nat inside" under interface vlan1, anyway, check output of "show int atm0" and "show dsl interface" to check line up and passing a packets.

kayasaman Tue, 07/24/2007 - 08:02

I used the command: router(config)#interface dialer 0

router(conf-if)#ppp authentication chap callin

but it still doesn't work after switching my line from old router - it keeps saying line protocol is down?

Paolo Bevilacqua Tue, 07/24/2007 - 08:20

What I'm telling you is that unless line is up as shown by "shot int atm0" and "show dsl interface", nothing will work. It may be a compatibility problem with the DSLAM. There is firmware available to correct this at:

ftp://ftp.cisco.com/pub/access/800/

Hope this helps, please rate post if it does!

kayasaman Tue, 07/24/2007 - 08:51

Thanks for that, sorry for being slow!

However the link you gave me keeps coming out with "connection refused"?

kayasaman Tue, 07/24/2007 - 09:13

Do I have to be subscribed specially for it (as in not guest access)? as I've just tried from 2 web browsers and Filezilla FTP app and same prob..

kayasaman Tue, 07/24/2007 - 09:29

Ignore last post I got in - I think my computers playing up. Sorry!

kayasaman Tue, 07/24/2007 - 10:50

Is there any documentation on upgrading the 800 series as the one I've found: http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094c07.shtml

is for 7000 series upwards?

If the basic principle is the same it means creating an ftp server from pc then downloading the image from the pc to the router.

I don't suppose there is a direct way through terminal?

Paolo Bevilacqua Tue, 07/24/2007 - 10:54

Just use tftpd32 that is a free download and works nicely. No way to do it without a TFTP / FTP / HTTP/ RCP server.

kayasaman Tue, 07/24/2007 - 15:22

Ok I transferred the file to the routers flash memory, now how do I get the system to use the binary?

I had a look at the upgrade command but it didn't work so I'm guessing I have to append a boot parameter somewhere?

Paolo Bevilacqua Tue, 07/24/2007 - 16:33

Please read the document in the same directory on how to install the adsl firmware.

After, verify installation with "show dsl interface".

kayasaman Tue, 07/24/2007 - 17:56

Thanks I think I upgraded fine, the only thing is that after running the command "show dsl interface atm 0" and "show interface atm" it doesn't tell me what version of firmware I'm using. After running: show dsl interface

Result is: ATM0

Alcatel 20190 chipset information

Line has not yet been activated. No information available.

DSL: Training log buffer capability is not enabled

kayasaman Wed, 07/25/2007 - 02:13

Brilliant, thank you so much I now have link and an IP!!! :-)

I think most of problems are over now, just whenever I try to ping outside the router now to test the connection it keeps trying to connect to the internal "ip name-server" instead of using dns provided by my isp and because of this pc not able to connect to internet. Is there a command for obtaining dns from isp or should I just clear the internal name-server?

Paolo Bevilacqua Wed, 07/25/2007 - 03:05

Hi,

glad to know the ADSL firmware has put you on-line. If you remove the name-servers from the configuration, the router will obtain them via PPP if you configure "ppp ipcp dns request' under dialer1.

Thanks for the nice rating and good luck!

kayasaman Wed, 07/25/2007 - 03:38

Ok I got dns servers in!

Strange thing is that if I now try and ping a domain like say yahoo it comes out with "unrecognized host or address, or protocol not running" and if I ping the dns servers it just says "protocol not running"

I don't know if this is a routing issue, ie I didn't set something up right or if I need to configure RIP?

Oh and btw thanks for the patience if there was a rating for that you'd definately get tops!!!

Paolo Bevilacqua Wed, 07/25/2007 - 03:45

No need for rip. Actually the name servers on the router are not important, anyway, if you have problems, do "show ip dns view" and check that the right addresses are in there.

Also check the access-list you are using in NAT statement.

This forum is to help anyone that has the patience of listening to advice and I whish something like that existed when I startedplaying with routers many many years ago.

kayasaman Wed, 07/25/2007 - 06:09

"Show ip dns view" didn't work so I tried "show ip dns statistics/primary"

"primary" returned blank and "statistics" returned 0

As for my nat I have the lines:

ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255

ip nat source list 1 interface dialer0 overload

ip nat source list 100 dialer0 overload

My atm0 ip address is 200.200.100.1 255.255.255.0

I tried to create a new pool, pool2 which would be from 200.200.100.0

But when I use ping command it shows that it's connecting to dns servers, dns 1 and dns 2 and displays the ip addresses but still comes up with the same issue!

I'm really not sure where to start looking now, unless maybe I create a vlan between dns pool1 and pool2 ???

kayasaman Wed, 07/25/2007 - 07:19

I managed to create an access-list:

access-list 1 permit 192.168.1.0 0.0.2.0 access-list 1 permit 200.200.100.0 0.0.200.0

then used this command: ip nat inside source list 1 pool no-overload to allow everything inside access

but I still keep getting dns errors?

Paolo Bevilacqua Wed, 07/25/2007 - 07:37

Hi, the access-list should be like

access-list 1 permit 192.168.1.0 0.0.0.255

Do not use ATM address in access-list.

You do not need to use any VLAN neither.

kayasaman Wed, 07/25/2007 - 09:27

Ok hopefully I've setup my nat correctly with the command you suggested.

I'm still getting the dns issue though and after googling I discovered this: http://www.cisco.com/warp/public/105/reversedns.html

which I don't think is for dns provided by isp, never the less I tried playing and now after I type ping url it comes out with dns as 255.255.255.255 ?? I don't know how to clear this, I typed no ip name-server and no ip subnet-zero but still it's there?

The problem I was getting before modifying my dns setup was:

Router# ping www.novell.com Translating "www.novell.com"...domain server (dns 1, dns 2) % Unrecognized host or address, or protocol not running.

and now I see:

Router# ping www.novell.com Translating "www.novell.com"...domain server (255.255.255.255) % Unrecognized host or address, or protocol not running.

Paolo Bevilacqua Wed, 07/25/2007 - 09:34

Hi, seems like the ISP is not passing the DNS address via IPCP, so you could remvoe that command and just configure the DNS statically.

kayasaman Wed, 07/25/2007 - 11:01

I've now tried with static dns and same problem: Unrecognized host or address, or protocol not running.

which leads me to believe that I have to activate something like a deamon to start the protocol, or my routing is not setup correctly?

I've attached my current config so maybe there's something I haven't put or something I have which shouldn't be there!

Maybe even it has something to do with the dialerlist 1 protocol ip permit command?

Either way I don't see any reason why it shouldn't work with my isp as I previously had a D-Link and now an Action Tech modem/router hooked up and everythings fine with them.

Attachment: 
Paolo Bevilacqua Wed, 07/25/2007 - 11:23

Hi,

please configure:

interface BVI1

ip nat inside

no ip nat pool pool2 200.200.100.0 200.200.200.0 netmask 0.0.0.255

no ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255

no ip nat source list 1 interface Dialer0 overload

no ip nat inside source list 1 pool no-overload

no ip route 0.0.0.0 0.0.0.0 ATM0

ip nat inside source list 1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 dialer1

After you have basic connectivity working please explain what do you want to achieve using nat pools and we can give you some configuration advice.

There are no whatsoever daemons to start in cisco IOS.

kayasaman Wed, 07/25/2007 - 12:45

Wow, thanks alot I'm almost online! I can ping outside from the router :-)

Through the above config eveything is fine routerwise but I can't access the internet from my machines still - as you can see from the running-config the ethernet interface has been bridged with the wireless interface just to make things simple while I learn more about how to use the routers capabilities.

Basically what I would like to achieve right now is to be able to connect the 7 computers on my network to the internet and to each other via wireless interface, I have more plans for later but first I would just like to learn about my router so I will be ready when I come to make changes.

And by using nat pools I was just trying to follow the "basic setup" cisco documentation in order to get things working - without knowing how they work I guess!!

Paolo Bevilacqua Wed, 07/25/2007 - 17:50

Hi, I don't think the radio interface supports routing, normally it's bridged to a bvi and you do routing from there.

Post again nat config.

Paolo Bevilacqua Thu, 07/26/2007 - 03:09

Hi, as indicated previously,please configure:

ip nat inside source list 1 interface Dialer0 overload

kayasaman Thu, 07/26/2007 - 03:19

hmm.... I thought I put the line in? Must have missed it!

Just entered it and tested from pc but still no luck :-( no url is resolving

Paolo Bevilacqua Thu, 07/26/2007 - 03:28

Please configure correct dns server address under DHCP pool. You also do not need "import all".

kayasaman Thu, 07/26/2007 - 04:12

Bingo I'm online!!! :-))

THANK YOU SO MUCH!

Something I'd like to understand though is that in the dhcp dns-server I put my isp's dns entry statically. Is there a way to make a dynamic dns resolution so that say if the dns server address changes the router will automatically change without me having to re-append the static config of each one of my computers?

Paolo Bevilacqua Thu, 07/26/2007 - 04:57

Try removing the dns-server from dhcp poll. That should use the servers configured on the router. Then try removing them from configuration and to see if in fact these are passed by IPCP, this can be confirmed with "term mon" and "debug ppp negotiation".

kayasaman Thu, 07/26/2007 - 08:40

I removed the dhcp dns-server but I had no luck in resolving dns.

I am connecting some of my machines via static ip and testing the internet through them at the moment. So if I put 62.xx.xx.203 in the static dns 1 entry with the dhcp dns server as the same number it works fine.

After removing the dns server from dhcp, I tried using 192.168.1.1 in the dns 1 entry, then I tried leaving it blank. Through both methods nothing resolved so I reverted back to the old config with dhcp dns server engaged.

Through my old routers I used to have 192.168.1.1 in the static dns 1 entry and every thing worked fine. This is kind of confusing as it leads me to believe that either the nat was translating the dns or they had a vlan in place.

Any thoughts?

Paolo Bevilacqua Thu, 07/26/2007 - 09:20

Other routers do by default respond to dns queries to their address, by forwarding to real dns server.

Cisco doesn't do that unless you configure it.

It is not necessary because it works fine passing the real DNS server to clients. And if you want one that always works and it's easy to remember, try 4.2.2.1.

kayasaman Thu, 07/26/2007 - 10:11

It's me being a beginer again but I didn't get the 4.2.2.1. Is that a default route between discovered dns from isp to dhcp dns or is it ip for dns once configured to relay from isp to host client?

Also do you know of any web articals or cisco pages that might help me better understand my router? I've downloaded loads of pdf's from cisco.com which are setup guides and howto's but I guess I need something that will teach me more about the way in which things can be done, rather then loose generic templates.

andriyhar Sat, 07/28/2007 - 12:51

Try this one.

-------------------------------------

conf t

ip dhcp pool dpool1

no domain-name cisco.router

end

-------------------------------------

conf t

ip dhcp pool dpool1

no dns-server 192.168.1.1

end

-------------------------------------

conf t

ip dhcp pool pool1

default-router 192.168.1.1

dns-server REAL IP FROM INTERNET PROVIDER

lease infinite

-------------------------------------

conf t

no ip domain name cisco.router

end

--------------------------------------

conf t

ip nat inside source list 1 interface Dialer0 overload

end

---------------------------------------

conf t

access-list 1 permit 192.168.1.0 0.0.0.255

end

----------------------------------------

conf t

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

end

-----------------------------------------

conf t

interface ATM0.1 point-to-point

no snmp trap link-status

pvc 0/38

encapsulation aal5snap

protocol ppp dialer

dialer pool-member 1

end

kayasaman Sun, 07/29/2007 - 04:03

Thanks!

I removed the dhcp dns-server and put the dns ip's from my isp into pc network config. All the old config from router is same though and seems to work fine.

andriyhar Sun, 07/29/2007 - 04:42

Hi.

When you make change on router yours PC get connection automatic.

kayasaman Sun, 07/29/2007 - 13:25

As my isp has 2 dns servers does that mean that if I create 2 pools - pool 1 and pool 2 with each dhcp dns relay as server 1 and 2 that under a static network config in pc the dns servers will still resolve?

Also it would be great to forward the auto dns given by ipcp to any lookup to the default router ip 192.....1 so that if I put 192......1 in the dns config of pc that it would translate any queries to the isp provided dns by ipcp!

Paolo Bevilacqua Sun, 07/29/2007 - 13:41

Hi,

no having more than one pool won't help.

Really you should not worry about the dns addresss, these never change.

If you feel in the mood of trying something else, search "configuring ios dns server", this way you would be able to use router as dns just like the consumer grade routers do.

andriyhar Sun, 07/29/2007 - 14:56

Like this.

------------

ip dhcp pool pool1

network .......... subnet..........

default-router ............

dns-server one and another xxxxxxxxxxxxxx xxxxxxxxxxxxx

lease infinite

kayasaman Mon, 07/30/2007 - 01:06

Hmmm....

I think I'm gona take some time out on this topic and google a bit to try and see if i can learn a bit more on this topic to get some more ideas!

Thanks again to everyone for the help :-)

Actions

This Discussion